Problems with GDB Commands in Quick Debug

Sysprogs forums Forums VisualGDB Problems with GDB Commands in Quick Debug

This topic contains 3 replies, has 2 voices, and was last updated by  support 3 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #23083

    MikeGranby
    Participant

    If you start Quick Debug and indicate that you wish to enter GDB commands, the dialog shown in the attached image S1 appears. This allows me to enter commands as you would expect, but to close the dialog I have to press the Debug with Visual Studio button. This starts the debugging process, but the window shown in the attached image S2 appears, trying to resolve the location the PDB database for the target’s dynamic loader, which of course doesn’t exist. I’m using the latest preview version and still getting this result. I’d like to use the Send Commands option as it would allow me to shell out to a batch file to download my binary to the target, but this is stopping me…

    Attachments:
    You must be logged in to view attached files.
    #23087

    support
    Keymaster

    Hi,

    The screen shown in s2.png means that the target is stopped at a location that doesn’t have any source files associated with it. It should not interfere with anything – you can press F5 to continue debugging, or use the GDB Session window to enter further gdb commands.

    #23088

    MikeGranby
    Participant

    Thanks for this. That makes sense. My idea didn’t work anyway, as GDB already needs the program in place before the extra commands are executed. Oh, well. Back to my original suggestion: It would be great if you could add an option to Quick Debug to run a local program or script before debugging. Thanks for an excellent product, by the way!

    #23090

    support
    Keymaster

    Hi,

    No problem and thanks for the kind words. Please try the build posted in this thread.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.