Failed to profile Linux prgorame when debug as root(use sudo)

Sysprogs forums Forums VisualGDB Failed to profile Linux prgorame when debug as root(use sudo)

Tagged: 

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #35414
    linshi
    Participant

    Hi,

    I get the following error when profile with debugging  as root(use sudo).

    How to setup and generate the correct file for it?

    syscall failed: No such file or directory
    error opening /tmp/901059da-2b0a-44dd-b5e8-0de4e58dcb93-shared-mem-vgdb-80885-by-root-on-??? shared memory file

    #35426
    support
    Keymaster

    No problem. Please let us know the email address associated with your license so that we could link it to your support profile.

    #35427
    linshi
    Participant

    I am still using trial verison since last week,  I will purchase one  before the trial ends and some problem is solved.

    #35428
    support
    Keymaster

    Hi,

    This looks like an incompatibility between valgrind and your kernel and not something directly caused by VisualGDB.

    As far as our support goes, we can explain how VisualGDB launches valgrind and what modes it uses, however we would require an active license for that.

    #35439
    linshi
    Participant

    Hi,

    I am tring to get a custom edition license. I have requested for a academic discount but doesn’t get any feedback for now.

    #35441
    support
    Keymaster

    According to our records, we have replied to your inquiry with the details on the academic license purchase.

    #35569
    linshi
    Participant

    Hi,

    I have update the license, my email is  [redacted for privacy]

    Can you help me with this ?

    Thanks,

    Shiyuan Lin

    • This reply was modified 4 days, 4 hours ago by support. Reason: removed personal data
    #35576
    support
    Keymaster

    Hi,

    Thanks, we have linked your key to your profile. Regarding this error, please try enabling View->Other Windows->VisualGDB Diagnostics Console and starting a profiling session without debugging.

    If it still doesn’t work, please take a note of the valgrind command line shown in the VisualGDB diagnostics console. It will show the path to the profiled program and some other arguments.

    Please then try manually running valgrind with that program without any other options, e.g.

    valgrind /tmp/my-program

    Does valgrind work when launched manually? If yes, please post the exact command line you captured from VisualGDB Diagnostics Console and the exact command that worked manually.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.