Quick Debug using gdbserver

Sysprogs forums Forums VisualGDB Quick Debug using gdbserver

This topic contains 6 replies, has 2 voices, and was last updated by  MikeGranby 3 months, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #23078

    MikeGranby
    Participant

    Is there anyway to launch a quick debug on an existing project using gdbserver rather than GDB? I have some existing Linux code that is built using pre-existing scripts and project files, and I’d rather not make changes to those. Right now, I’m able to debug using Quick Debug and gdb, but gdbserver would be better. I can’t see a way to do it, in which case, could you make this a feature request? Thanks!

    #23079

    MikeGranby
    Participant

    As soon as I wrote that, I found it. I just have to check the “Use cross-compiler…” box. Doh!

    #23080

    MikeGranby
    Participant

    I will add one thing, though: It would be fantastic to be able to run a command on the local Windows build machine before the quick debug begins. That would allow be to SCP the binary to the target device, and avoid having to do a CIFS mount or insert another step in my workflow.

    #23089

    support
    Keymaster

    Hi,

    No problem, please try this build: http://sysprogs.com/files/tmp/VisualGDB-5.4.10.2627.msi

    We have added a quick workaround for this. Please create a separate project and configure the deployment via custom pre-debug steps, then copy the <CustomDebug> element from the .vgdbsettings file into the %LOCALAPPDATA%\VisualGDB\QuickDebugPresets\<preset>.quickdbg directly under the QuickDebugPreset element.

    We will add the proper GUI for editing those steps from the QuickDebug window in the next major VisualGDB release (after v5.4) as a part of our redesign of the QuickDebug GUI.

    #23091

    MikeGranby
    Participant

    Excellent! That works great! The only (very minor) issue I had is that the copy-files tool seems to apply some sort of heuristic to decide whether to chmod +x the files. My executable had an extension of .out for historical reasons, and while the so’s that it copied across got chmod-ed, the executable end up un-runnable. All I had to do was remove the extension and everything now works great. Is this a setting somewhere? Thank you for the very prompt response!

    #23092

    support
    Keymaster

    Hi,

    Yes, please use the Tools->Options->VisualGDB->SSH->Executable Extensions setting.

    #23093

    MikeGranby
    Participant

    Excellent! I shall now go to bed happy!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.