First start after Installation (Win2k8 Server / Win 7)

Sysprogs forums Forums WinCDEmu First start after Installation (Win2k8 Server / Win 7)

This topic contains 10 replies, has 3 voices, and was last updated by  gratchen 10 years, 11 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #79

    Anonymous
    Participant

    Hi,

    When I mount an image for the first time after the installation I get an Information window:

    Cannot find C:Windowssystem32DriversBazisVirtualCD.sys
    Update WinCDEmu driver?

    Why doesn’t the installer place the .sys file in this directory during installation?

    One additional question:

    Is it possible to change the drive letter that WinCDEmu uses to a fixed one?
    I like it that WCDE always removes the virtual drive after unmounting an image
    but an option to not use the next free drive letter but a fixed one would be quite nice.

    Regards,
    Highend

    #1042

    support
    Keymaster

    When WinCDEmu is first installed, it sets up the driver for the virtual disk bus. As no virtual drives are present at that moment, the driver is not installed. This will maybe[/i/ be fixed in further versions by flushing an empty virtual drive during installation and updating the drivers.
    Drive letter selection is a little bit tricky, however, I have an idea to implement something similar in the next version. However, note that the driver letter cannot be reserved while virtual CD is not active (if you insert a USB FLASH disk, it can still ocupy the letter), however, it will be possible to assign a given letter to a newly mounted image, instead of default one.

    #1043

    Anonymous
    Participant

    @bazis wrote:

    When WinCDEmu is first installed, it sets up the driver for the virtual disk bus. As no virtual drives are present at that moment, the driver is not installed. This will maybe[/i/ be fixed in further versions by flushing an empty virtual drive during installation and updating the drivers.

    Ok, thanks for the explanation. I hope it’s more than a “maybe” *g*

    Drive letter selection is a little bit tricky, however, I have an idea to implement something similar in the next version. However, note that the driver letter cannot be reserved while virtual CD is not active (if you insert a USB FLASH disk, it can still ocupy the letter), however, it will be possible to assign a given letter to a newly mounted image, instead of default one.

    It wouldn’t matter that it is not possible to reverse it while the virtual CD is not active as long as we can define a default letter (and that will vanish like now when the CD is unmounted).

    If you need somebody to test these changes just tell me in this thread (if you like).

    Thanks for listening to the users regarding changes / feature requests!

    Regards,
    Highend

    #1044

    Anonymous
    Participant

    I do not like tricky one. Simpl is better. Light is better. No GUI necessary. Just doblue click ISO.
    I JUST want both drivers next time which is JUST digital signed.

    Regards,

    #1045

    support
    Keymaster

    The GUI will still be simple and will not cancel the simplicity of single-click mounting. You’ll be able to choose whether to prompt for a drive letter on each mounting, or use the default one.
    As for signed drivers, next version will be signed by sysprogs.org certificate available for installing, that will allow running drivers on Vista/Win7 x64 in ‘driver test mode’ (Bcdedit.exe -set TESTSIGNING ON). Normal signing costs 500$ per year and, thus, is not a point for free software.

    #1046

    Anonymous
    Participant

    @bazis wrote:

    The GUI will still be simple and will not cancel the simplicity of single-click mounting. You’ll be able to choose whether to prompt for a drive letter on each mounting, or use the default one.

    I’m not sure if this is what I like to see *g*

    Atm we have this behaviour of WinCDEmu:
    When an image is mounted WinCDEmu reserves the first free drive letter (a: and b: are not choosen if there is no floppy drive).
    So when you have 3 Partitions and one DVD-Rom you have letters C:, D:, E: and F: reserved and the first image would take the G: letter.
    Every additional image would tage the next free letter etc.

    What I’d like to have:
    The old behaviour should be the standard for every user. Plus we get an option to set a new “starting drive letter”. E.g. I like to mount my images to the
    driveletter V: (like “V”irtual). So the first mounted image get’s the V: and every additional image W:, X:, etc.

    I hope that makes it a bit more clearer 🙂

    Regards,
    Highend

    #1047

    Anonymous
    Participant

    I can’t edit my own posting…

    Please don’t let WinCDEmu prompt for a drive letter on _every_ image mount (or make it an additional option that is not tied to what I wrote in my last post)!

    Thx,
    Highend

    #1048

    support
    Keymaster

    It does not prompt at every mount, as soon as you select “manage drive letters automatically”.

    #1049

    Anonymous
    Participant

    Hi can someone tell me how I get rid of the “Test Mode” words which appear on all for corners of the screen and the evaluation message at the top. These appeared after I installed WIN CD-EMU on Win 2008 server 64-bit. Thanks

    #1050

    support
    Keymaster

    Unfortunately, no. You can read more here: http://www.sysprogs.org/signing/.

    #1051

    gratchen
    Participant

    The Windows 7 has embossed the desktop with numerous water marks that determine and come into view if the condition warranted, comparable to Windows Vista. For illustration, “For testing purposes only” determine and come into view if the customer installs a beta or RC copy of Windows 7, “Evaluation copy” if the operating system installed is not stimulate up till now, “Test Mode” when facilitating the testsigning method (permit non-CA signed self-signed official document to be used), “Safe Mode” when booting into Safe Mode, and etc.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.