Builds stopped working

Sysprogs forums Forums VisualGDB Builds stopped working

This topic contains 12 replies, has 2 voices, and was last updated by  support 5 days, 6 hours ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #22582

    Nakueliofix
    Participant

    Builds have suddenly stopped working.  After a few weeks of not using VisualGDB I attempted to make a build and it gave an error (see below).

    I recreated a new project to see if I that resolved it, no luck.  I also tried updating to the latest release and it still gives the same problem.  MSVC 2015, Windows 10.

    Error:

    1>—— Build started: Project: igc.nisttime.git_linked, Configuration: Release Win32 ——
    1>
    1>  Unhandled Exception: System.IO.FileLoadException: Mixed mode assembly is built against version ‘v2.0.50727’ of the runtime and cannot be loaded in the 4.0 runtime without additional configuration information.
    1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(41,5): error MSB3073: The command “”C:\Program Files (x86)\Sysprogs\VisualGDB\\VisualGDB.exe” /build “C:\Code\Linux2015\igc.nisttime.git_linked\igc.nisttime.git_linked\igc.nisttime.git_linked.vcxproj” “/solution:C:\Code\Linux2015\igc.nisttime.git_linked\igc.nisttime.git_linked.sln”  “/config:Release” “/platform:Win32″” exited with code -532462766.
    ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

     

    #22583

    support
    Keymaster

    Hi,

    Thanks for contacting us. According to our records, your support period has expired. In order to keep on receiving technical support, please renew your license or let us know the email associated with your new license key.

    #22584

    Nakueliofix
    Participant

    *cry*  That will mean I’m down another couple days for that paperwork to go through.

    Nothing to be done about that, I guess.

    #22586

    support
    Keymaster

    Hi,

    We could issue you a trial extension voucher so you could check if the latest VisualGDB 5.4 resolves the problem, but unfortunately we are not able to offer any personalized technical support unless the support period is renewed.

    #22595

    Nakueliofix
    Participant

    Oh yay!  Paperwork all through fast…   Should be good now.  🙂

    #22600

    support
    Keymaster

    Hi,

    Thanks for renewing your license! It looks like your forum email was different from the email used in your order, so our system was not automatically picking up the latest key. We have linked them together now in our system.

    Regarding the error, it looks like you are using an older VisualGDB version that does not include a configuration file listing all compatible .Net runtimes. This can be fixed via one of the following options:

    • Updating to VisualGDB 5.4 Preview 8.
    • Downloading the attached .config file and placing it in the same directory as VisualGDB.exe.
    • Installing the .Net 2.0 runtime via Control Panel -> Add/Remove Programs.

    Let us know if you encounter any further problems and we will be happy to help.

    Attachments:
    You must be logged in to view attached files.
    #22603

    Nakueliofix
    Participant

    Tried updating, that didn’t change anything..

    I downloaded the attached file and noticed there was already a similar named file to the attached one (Contents are identical)

    I don’t think I can install .Net 2.0 though…  🙁

    #22604

    support
    Keymaster

    Hi,

    OK, thanks for checking this. If updating doesn’t help, there might be a system setting that is blocking the VisualGDB.exe assembly, or the problem is caused by a different assembly.

    Please try running the build command line shown in the log manually:

    Do you get the same error? If yes, does running VisualGDB.exe without arguments also result in the same behavior? If no, please try setting the “VISUALGDB_VERBOSE_OUTPUT” environment variable in a command line prompt and running the full build command line again. This should produce a more detailed error log.

    Another option would be to try adding the <startup> element to the .config file as shown in this thread: https://stackoverflow.com/questions/6425707/mixed-mode-assembly-is-built-against-version-v2-0-50727-of-the-runtime

    #22605

    Nakueliofix
    Participant

    Okay, got it working again.

    VisualGDB.exe.config had to be modified thusly:

    <?xml version=”1.0″ encoding=”utf-8″ ?>
    <startup useLegacyV2RuntimeActivationPolicy=”true” />
    <configuration>
    <startup>
    <supportedRuntime version=”v4.0.30319″/>
    <supportedRuntime version=”v2.0.50727″/>
    </startup>
    </configuration>

    #22606

    Nakueliofix
    Participant

    Blah.  Spoke too soon, VisualGDB.exe actually runs, but I’m still not building.

    1>—— Build started: Project: igc.nisttime.git_linked, Configuration: Release Win32 ——
    1>  Build/launch failed: The type initializer for ‘ln1’ threw an exception.
    1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(41,5): error MSB3073: The command “”C:\Program Files (x86)\Sysprogs\VisualGDB\\VisualGDB.exe” /build “C:\Code\Linux2015\igc.nisttime.git_linked\igc.nisttime.git_linked\igc.nisttime.git_linked.vcxproj” “/solution:C:\Code\Linux2015\igc.nisttime.git_linked\igc.nisttime.git_linked.sln”  “/config:Release” “/platform:Win32″” exited with code 1.
    ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

    I imagine it’s the same thing…  or some variant.  *Pokes at it*

    #22610

    support
    Keymaster

    Hi,

    Strange. We have rechecked all the assemblies shipped with VisualGDB and could not find any mixed-mode ones.

    The error looks like the .Net runtime is failing to load the VisualGDB settings types. Could it be a corrupt .Net installation? Can you confirm that VisualGDB runs as expected on other machines in the same domain/with the same group policy?

    We have also added extra logging to this build: http://sysprogs.com/files/tmp/VisualGDB-5.4.9.2552.msi

     

    Please try reproducing the problem with it (enable verbose mode by adding “/v” to VisualGDB’s arguments). It should show a much more detailed exception report that should help narrow this down.

     

    #22613

    Nakueliofix
    Participant

    I was able to track down what I did wrong in my modifying the config.

    This is now the corrected file that works for me:

    <?xml version=”1.0″ encoding=”utf-8″ ?>
    <configuration>
    <startup useLegacyV2RuntimeActivationPolicy=”true” />
    <startup>
    <supportedRuntime version=”v4.0.30319″/>
    <supportedRuntime version=”v2.0.50727″/>
    </startup>
    </configuration>

    #22616

    support
    Keymaster

    Hi,

    Thanks for sharing this. We have double-checked the config files from Visual Studio itself and it looks like it also uses the same flag, so we added it to the config file that comes with VisualGDB as well. Hence you won’t need to edit the file next time you update VisualGDB.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.