MikeGranby

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • in reply to: Payment Required After Upgrade? #29270

    MikeGranby
    Participant

    I understand fully, and as I say, I love the product. I was just surprised to find myself locked out! ūüôā

    in reply to: VisualGDB Not Showing Up in VS 2010 #26320

    MikeGranby
    Participant

    The most obvious bit is…

    The component assembly doesn’t exist:
    C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\SysprogsVisualGDB\Sysprogs\BuildUpToDateCheck2015.dll

    …and indeed that file does not exist.

    • This reply was modified 1 year, 4 months ago by  MikeGranby.
    • This reply was modified 1 year, 4 months ago by  MikeGranby.
    • This reply was modified 1 year, 4 months ago by  MikeGranby.
    in reply to: Pointer Incorrectly Displayed #26316

    MikeGranby
    Participant

    Same issue, I’m afraid. It’s not a VisualGDB project so I can’t capture a log that way. (It’s build using an in-house tool that redirects VC to use GCC.) But I’ve attached the GDB interactions captured from the debug window, and also a capture of the Local Variables window showing the issue.

    Attachments:
    You must be logged in to view attached files.
    in reply to: VisualGDB Not Showing Up in VS 2010 #26315

    MikeGranby
    Participant

    Here are the extracts from the startup log that mention GDB…

    in reply to: VisualGDB Not Showing Up in VS 2010 #26310

    MikeGranby
    Participant

    Had already installed and remove an arbitrary extension to refresh the cache, but tried again (Hide Main Menu, FWIW) and still no joy. The VisualGDB commands do not appear in the Customize dialog.

    in reply to: Import Folder Missing #25160

    MikeGranby
    Participant

    Okay. I found it. It’s disabled when I’ve got the project in the Win32 configuration, but it comes back if I flip to one of my custom Linux configurations. (I’m not using VisualGDB’s configuration type, but instead some custom MSBuild magic.) Sorry for the false alarm! I’ll get my coat… ūüôā

    in reply to: Quick Debug Fail w/ 5.4 Beta 2 #23424

    MikeGranby
    Participant

    Makes sense. Thank you again for the attentive and rapid support, and for a great product!

    in reply to: Quick Debug Fail w/ 5.4 Beta 2 #23422

    MikeGranby
    Participant

    Sounds good. I guess the question is why it used to work and then stopped with 5.4?

    in reply to: Quick Debug Fail w/ 5.4 Beta 2 #23420

    MikeGranby
    Participant

    Just to clarify: The project is a Visual Studio Cross-Platform Linux project set to build on a remote Linux machine. I’m then running it on a different machine, an embedded Linux device. So the source code won’t exist on the debug target. It’ll just be on the Windows host machine and on the Linux build machine, the latter of which won’t be visible to the debug target. Do you still want me to proceed?

    in reply to: Quick Debug Fail w/ 5.4 Beta 2 #23415

    MikeGranby
    Participant

    Turning off the ‘Hide Missing Source Files’ option does indeed fix the problem, so it looks like it’s thinking that a file is missing when in fact it is available. If I install the build you provided and have this option checked, the same failure occurs. The resulting diagnostic log is attached. It looks like it’s seeing the Linux-style path from the build machine, and not converting it to the Windows equivalent. Disabling the option still fixes the problem.

    Attachments:
    You must be logged in to view attached files.
    in reply to: Quick Debug Fail w/ 5.4 Beta 2 #23386

    MikeGranby
    Participant

    I tried the new release, and…

    1. The SSH issue is now resolved.
    2. The Intellisense issue from 5.3r8 is still resolved.
    3. The original failure to debug is still resolved.
    4. The source code still does not display correctly.

    I tried the stack trace approach, and that did not work. Double-clicking on the “main” entry did nothing. Selecting Show Source produced the Frame Not In Module window. Selecting Show Disassembly worked, and shows the assembly with the correct interspersed source lines. Attached is the GDB log from the failing case with the latest release, and the working case with 5.3r8. A quick diff shows very little difference between the files, except a change in the order of a few commands.

    Attachments:
    You must be logged in to view attached files.
    in reply to: Quick Debug Fail w/ 5.4 Beta 2 #23302

    MikeGranby
    Participant

    Yep, with the build you posted, when I do debug, I get the unknown source file page every time. Under 5.3, it would correctly go to my application’s main, and then show the various breakpoints I’d set. With the posted build, the breakpoints would be hit and I could show the mixer assembly, but the pure source was never displays.

    in reply to: Quick Debug Fail w/ 5.4 Beta 2 #23300

    MikeGranby
    Participant

    That seems to fix the debug issue, but the SSH Connection Manager now won’t let me open a console. (See attached.)

    Also, I don’t seem to be getting proper source code display, but let me confirm that…

     

    Attachments:
    You must be logged in to view attached files.
    in reply to: Quick Debug Fail w/ 5.4 Beta 2 #23286

    MikeGranby
    Participant

    Since it wouldn’t let me upload the preset…

    <?xml version=”1.0″?>
    <QuickDebugPreset xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance” xmlns:xsd=”http://www.w3.org/2001/XMLSchema”>
    <InitialBreakpoint>main</InitialBreakpoint>
    <InteractiveStartup>false</InteractiveStartup>
    <Name>mCore</Name>
    <Timestamp>2019-01-06T12:22:34.9732384-05:00</Timestamp>
    <Settings xsi:type=”com.visualgdb.quickdebug.program”>
    <RemoteHost>
    <HostName>mcore-local</HostName>
    <Transport>SSH</Transport>
    <UserName>root</UserName>
    </RemoteHost>
    <ToolchainID>
    <ID>linaro-gcc-7.3.1</ID>
    <Version>
    <GCC>7.3.1</GCC>
    <GDB>(Linaro_GDB-2018.05)</GDB>
    <Revision>0</Revision>
    </Version>
    </ToolchainID>
    <DebuggedProgram>
    <SkipWhenRunningCommandList>false</SkipWhenRunningCommandList>
    <Command>/tmp/bin/LED_Server</Command>
    <Arguments />
    <WorkingDirectory />
    <Environment>
    <Records />
    </Environment>
    <BackgroundMode xsi:nil=”true” />
    </DebuggedProgram>
    <GenerateCtrlBreakInsteadOfCtrlC>false</GenerateCtrlBreakInsteadOfCtrlC>
    <RunGDBUnderSudo>false</RunGDBUnderSudo>
    <CrossSettings>
    <LocalProgramCopy>J:\Monico\GcLab\Unify\bin\ARM\Debug\bin\LED_Server</LocalProgramCopy>
    </CrossSettings>
    </Settings>
    <IsShared>false</IsShared>
    </QuickDebugPreset>

    • This reply was modified 2 years, 1 month ago by  MikeGranby.
    in reply to: Quick Debug using gdbserver #23093

    MikeGranby
    Participant

    Excellent! I shall now go to bed happy!

Viewing 15 posts - 1 through 15 (of 21 total)