John Devereux

Forum Replies Created

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • in reply to: esp32 jtag clock setting stuck at 3000kHz #24475

    John Devereux
    Participant

    Now I am finding it harder to reproduce the problem, and never when I am recording video! I am starting to think the overhead of video recording fixes it 🙂

    It still happens occasionally but it is not a problem for me now, if I manage to get it repeatable again I will f0llow up.

    Thanks for your help

    John

     

    in reply to: esp32 jtag clock setting stuck at 3000kHz #24462

    John Devereux
    Participant

    OK, to be clear, it works fine provided I use the “test” button before closing the dialog. So I do not have a problem any more.

    But it is still true that if I just change the setting and press OK, the old value is used.

    I reproduced the same problem with a default esp32 CMake project using the hello world example.

    Then I repeated this so I could get some screenshots for you. This time the created project failed to load with errors about cmake cache.

    So I reloaded the project and now I am unable to reproduce the problem!

    I went back to the original project. Sometimes it accepts the change without testing, sometimes it does not. Is it dependent on how long I wait before checking? There is background project reconfiguration happening in the output window.

    The projects are started with a workflow like

    File/new/project

    Choose ESP32/ESP8266 IDF/ADF project wizard … create

    Create a new CMake project based on sample

    ESp32 toolchain, v3.2 SDK

    get-started/hellow world

    Choose the detected segger jlink, accept defaults

    ..

    Go into project debug settings, change 3000kHz to 4000kHz, press OK.

     

     

    Attachments:
    You must be logged in to view attached files.
    in reply to: esp32 jtag clock setting stuck at 3000kHz #24452

    John Devereux
    Participant

    Ah it works OK if I use the “Test” button before applying the setting 🙂 So I guess it is working as intended.

    You could perhaps grey out the Apply & OK buttons until this is done.

    Thanks

    John

     

Viewing 3 posts - 1 through 3 (of 3 total)