XML file not being imported

Sysprogs forums Forums VisualGDB XML file not being imported

This topic contains 3 replies, has 2 voices, and was last updated by  support 5 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #9993

    arenalds
    Participant

    In step 10 of http://visualgdb.com/tutorials/linux/import/, I chose “copy sources locally and upload files during build”.  I made sure to specify that *.xml files are added to the filter.  My XML file copied but had to be manually added to the Visual Studio project.  Is there a way to have this done automatically?  And even after I did it manually and then updated the XML file, it didn’t get copied to the Linux box when I compiled.  Am I missing something?

    #9997

    support
    Keymaster

    Hi,

    Yes, please add *.xml to the “copied file masks” under VisualGDB Project Properties -> Project Settings.

    #10004

    arenalds
    Participant

    First, as I said, the XML file is copied when I add “*.xml” to the wizard filter.  But it is not added to the VS Project.  How do I make this happen?

    Second, the filter includes “*.xml” but the file is not being copied from my Windows box the Linux server when compilation occurs.

    Can you please explain how to resolve both of these?

    #10005

    support
    Keymaster

    Hi,

    Sorry about the confusion. You can configure VisualGDB to import the .xml files via Tools->Options->VisualGDB->General->Files->Source extensions to import.

    Regarding the copying, please double-check that the xml file is located inside the directory that is configured for copying. You can enable the verbose mode (Tools->Options->VisualGDB->General->Output->Enable Verbose Output) to see detailed information on the files that get uploaded. If you see other files from that directory, but not the XML file, please check your file transfer masks. If you don’t see any file from that directory, please double-check the source directory.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.