jotux

Forum Replies Created

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • in reply to: Issue with segger and flash erase/write #29486

    jotux
    Participant

    Changing the init script to this fixed my issue:

    target remote :$$SYS:GDB_PORT$$
    mon reset
    mon ExcludeFlashCacheRange 0x0803F800,0x08003FFF
    load

    Note that the documentation for ExcludeFlashCacheRange (here: https://wiki.segger.com/J-Link_Command_Strings) is incorrect. It should be <start>,<end>, not <start>-<end>.

    in reply to: Issue with segger and flash erase/write #29484

    jotux
    Participant

    The issue seems to be this “Allow caching of flash contents” setting in the J-Link GDB server. I’ll try to find a way to disable it from the commands in the debug menu.

    Attachments:
    You must be logged in to view attached files.
    in reply to: Issue with segger and flash erase/write #29480

    jotux
    Participant

    There’s some sort of disconnect between segger and the debug output. If I run the code and log it as I step across the erase function, the memory does not change in the memory window of VisualGDB. I’ve attached the log showing the memory segment as 0x0803F800 does not change as I step.

    If I view the memory with J-Mem as I debug I can see that the memory does get erased but at the same time it does not display correct in the VisualGDB memory window.

    See gif of memory here: https://imgur.com/aPVNwjE

     

    • This reply was modified 3 months, 3 weeks ago by  jotux.
    • This reply was modified 3 months, 3 weeks ago by  jotux.
    Attachments:
    You must be logged in to view attached files.

    jotux
    Participant

    A similar issue. For some reason now when I type an opening or closing brace the line un-indents.

    I see this in the intellisense log:

    [+7:37:43.437] Opening brace typed: bracket matching disabled, this occurence will be processed
    [+7:37:43.438] Automatically un-indenting a line with ‘{‘: ‘ uint16_t data {‘
    [+7:37:43.438] Indentation: ‘ ‘, expected: ‘ ‘

    Is there some way I can just use the built-in visual studio formatter? I’m constantly fighting with the VisualGDB formatting engine.

    Attachments:
    You must be logged in to view attached files.
    in reply to: Column insert brace deletes text and adds a new line #28633

    jotux
    Participant

    So switching the intellisense settings settings (VisualGDB Project Properties) to “Regular VC++ Intellisense”, then back to “Advanced Clang” made the problem go away. I’m not sure what the root cause is.

    Is there any way to just outright disable formatting from VisualGDB?

    in reply to: Column insert brace deletes text and adds a new line #28631

    jotux
    Participant

    See attached gif.

    Attachments:
    You must be logged in to view attached files.
    in reply to: Remote name could not be resolved #12258

    jotux
    Participant

    This error happens because VisualGDB cannot automatically download the source code for the system library you stepped in. If your PC does not have an Internet connection, simply choose “no” when VisualGDB suggests downloading the source code and it will show the disassembly instead.

     

    The code with the breakpoint is in my code, not library code. Also, I’m not getting any prompts asking me to download anything. I just have a breakpoint in one of my functions and when I click debug it starts, locks up for 10 seconds, then breaks on my code with the popup containing the error.

    in reply to: Remote name could not be resolved #12256

    jotux
    Participant

    The PC this is installed on is not (and cannot be) connected to the internet. This problem is new to version 5.3 as I didn’t have this problem on 5.2.

Viewing 8 posts - 1 through 8 (of 8 total)