Column insert brace deletes text and adds a new line

Sysprogs forums Forums VisualGDB Column insert brace deletes text and adds a new line

Tagged: 

This topic contains 5 replies, has 2 voices, and was last updated by  support 6 days, 1 hour ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #28628

    jotux
    Participant

    There’s some sort of issue with the VisualGDB format settings when inserting braces or parens while editing a column.

    Example code:

    int a = 0;
    int b = 1;
    int c = 2;
    int d = 3;

    If I column select just before the values and type a paren (or brace) the code erases everything between the top value and the last value, and inserts newlines:

    int a = (

    )3;

    See the attached images.

    I’ve tried disabling absolutely everything in Tools->Settings->Text Editor->C/C++(VisualGDB)->Formatting. It does not fix this issue. I’m pretty sure this is a VGDB issue, since I don’t have this issue in vanilla VS2019 C++ projects.

    Attachments:
    You must be logged in to view attached files.
    #28631

    jotux
    Participant

    See attached gif.

    Attachments:
    You must be logged in to view attached files.
    #28633

    jotux
    Participant

    So switching the intellisense settings settings (VisualGDB Project Properties) to “Regular VC++ Intellisense”, then back to “Advanced Clang” made the problem go away. I’m not sure what the root cause is.

    Is there any way to just outright disable formatting from VisualGDB?

    #28644

    support
    Keymaster

    No problem, we have fixed the issue in the following build: VisualGDB-5.5.7.3700.msi

    #28657

    jotux
    Participant

    A similar issue. For some reason now when I type an opening or closing brace the line un-indents.

    I see this in the intellisense log:

    [+7:37:43.437] Opening brace typed: bracket matching disabled, this occurence will be processed
    [+7:37:43.438] Automatically un-indenting a line with ‘{‘: ‘ uint16_t data {‘
    [+7:37:43.438] Indentation: ‘ ‘, expected: ‘ ‘

    Is there some way I can just use the built-in visual studio formatter? I’m constantly fighting with the VisualGDB formatting engine.

    Attachments:
    You must be logged in to view attached files.
    #28661

    support
    Keymaster

    No problem. This looks like a bug triggered by a combination of the “indent braces” style, disabled auto-pairing of brackets, and disabled auto-reformatting of statements. Since this combination of settings is very rare, indeed it was not covered by our tests.

    We have fixed it in the following build: VisualGDB-5.5.7.3703.msi

    Either way, you can disable VisualGDB’s code formatting logic if you switch from Clang IntelliSense to the regular VS IntelliSense (only works with projects based on VC++). You can find a detailed description of supported scenarios here: https://visualgdb.com/documentation/intellisense/.

    You can also find a searchable list of all VisualGDB settings automatically updated from the latest VisualGDB build here: https://visualgdb.com/settings/

     

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.