V. 5.4 prev. 8 references

Sysprogs forums Forums VisualGDB V. 5.4 prev. 8 references

This topic contains 10 replies, has 3 voices, and was last updated by  support 3 days, 3 hours ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #22570

    MystikReasons
    Participant

    I recently downloaded the newest version of VisualGDB and I really like the new features which came with it but I’ve encountered some weird situations.

    There are sometimes more references displayed over the function/variable/struct… than actually exist when you click on it to see every single one of them(see attached screenshots).

    It this an issue?

    What happened with my key combination for fast travelling to a definition/declaration of a function using “Ctrl(hover over it) and left click”?

    It doesn’t work anymore and I dont know if its because of this or visual studios update.

    And is there a key combination to turn off/turn on the references because its sometimes annoying?

    Attachments:
    You must be logged in to view attached files.
    #22574

    Ophidian14
    Participant

    I would also like to disable this as it’s useless in my project, “updating global symbol cache” never completes even after an hour, I also noticed that the “estimate” of time remaining has been removed.

    #22576

    support
    Keymaster

    Hi,

    You can disable the code annotations by clicking the wrench symbol at the bottom right corner of the popup to open the options window, and then disabling annotations for all C/C++ entity types.

    The “updating global symbol cache” is shown when VisualGDB is doing a global search (e.g. finding a definition, or all references). The remaining time should be shown after the progress advances a bit. If it never completes, please let us know if the progress is changing at all and if all the CPU cores on your machine are in use. If not, it might be stuck somewhere and we can help you pinpoint and fix it.

    #22578

    Ophidian14
    Participant

    I’m at 100% CPU, so much so that it slows down/almost locks up my computer at times.  I got the estimated time to display but the time just keeps going up and up.  One time I let it run overnight and when I came in the next morning, and tried to use it, it just started over and tried to rebuild it from scratch again.  What policy governs how this cache is invalidated?

    Attachments:
    You must be logged in to view attached files.
    #22580

    support
    Keymaster

    Hi,

    The estimated time is just a linear extrapolation based on the average speed so far. If the remaining time is going up, the parsing speed must be consistently going down. It could be caused by running out of RAM, or slow disk performance. Please let us know the total/free RAM shown in Task Manager when the cache is rebuilding.

    The cache is invalidated either when some of the build options (e.g. preprocessor macros) change, or when some of the files get outdated. The v5.4R8 build will show the exact reason for cache invalidation in the Clang IntelliSense Diagnostics Console (search for “invalidating cache chunk” messages).

    #22591

    MystikReasons
    Participant

    @support

    Wouldnt it be much easier for the user to have a key combination to turn them off/turn on(dissapear/appear)?

    And what is about my question yesterday about the many references?

    I installed it today on my laptop and now it seems to work like it should, did you make a fix?

    #22592

    MystikReasons
    Participant

    Update: The reference problem is still occuring sometimes on the same objects as mentioned yesterday.

    The weird thing is that its working sometimes and only display 5 references and sometimes its displaying 10 refernces

     

    Update2: I found a way to update the display. If you see the references in detail click on “Calls” and then back again to “References”. After that it loads the right amount of references. But it will change again to a wrong number of references if you write some more code and check it again

    • This reply was modified 6 days, 13 hours ago by  MystikReasons.
    • This reply was modified 6 days, 13 hours ago by  MystikReasons.
    #22611

    support
    Keymaster

    Hi,

    No problem, we have added a command to toggle the CodeJumps annotations via Edit->Advanced menu to this build: http://sysprogs.com/files/tmp/VisualGDB-5.4.9.2552.msi

    You can assign a keyboard shortcut to it via the Tools->Customize->Keyboard command.

    Regarding the references, it indeed looks like some glitch on our side, however unfortunately we were not able to reproduce it on our side. Please try narrowing down a specific sequence of steps that leads to it, or simply capture a video demonstrating the problem. This should help us see what is going on and add a fix for this.

    #22629

    MystikReasons
    Participant

    @support I couldn’t reproduce the glitch with the references yet but I found other interesting things.

    If I turn off the “CodeJumps” via a keyboard shortcut (I really love this feature) its still displaying me if I hover for example over a function the reference window with all the other options. Would it be possible that this window would also deactivate if I turn the CodeJumps off (or make an clickbox if you want to toggle/not toggle the reference window too if you toggle the codeJump Annotations)?

    My second thing I found: The reference window is always jumping a bit to the right if you select another topic in it. This is very confusing because sometimes the window jumps so much to the right that the mouse isn’t hovering over it any more and it just disappears and you have to open it again by hovering above the object. If you are lucky you can bring the window completely to the right border of the screen 😉

    Could this be somehow changed?

    • This reply was modified 4 days, 16 hours ago by  MystikReasons.
    #22631

    MystikReasons
    Participant

    Update: I found a way for me to reproduce the glitch every time:

    -Start Visual Studio

    -Open up your solution

    -Then watch the references (for me some of them are wrong – see screenshot #1)

    -Change the topic in the reference window to “Code/Data Relations” (for me – see screenshot #2)

    -Then change it back to “References” again: They are now displayed right (see screenshot #3)

    -If you close the solution/close Visual Studio and open up the solution again the glitch is there again.

     

    I think the glitch appears by the first time you start the solution where CodeJumps gathers all the needed data

    • This reply was modified 4 days, 16 hours ago by  MystikReasons.
    Attachments:
    You must be logged in to view attached files.
    #22657

    support
    Keymaster

    Hi,

    No problem. Please try this build: http://sysprogs.com/files/tmp/VisualGDB-5.4.9.2562.msi

    It will honor the “Suppress CodeJumps” setting for the QuickInfo tooltips.

    With the jumping popup window, it might be tricky. VS uses a rather hacky way to position the popup, so VisualGDB has to do some guessing on top of that to reposition it properly and it might not work correctly 100% of the time. If you could share a quick video showing the problem, we should be able to tell whether we could easily fix the behavior you are observing.

    The second glitch might be specific to some code. Unfortunately it looks like screenshots #1 and #3 are the same. Could you please double-check it and also share the .c file where this is reproduced?

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.