Solution Explorer Collapse

Sysprogs forums Forums VisualGDB Solution Explorer Collapse

This topic contains 6 replies, has 2 voices, and was last updated by  aronrubin 1 week, 5 days ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #22958

    aronrubin
    Participant

    It seems the solution explorer collapses every time I rebuild a VisualGDB CMake project. Sometimes the the tree is collapsed on a configure as well. This is not critical but it sure is a pain to expand the tree back to subfolders every time.

    Thank you in advance.

    #22960

    support
    Keymaster

    Hi,

    This would happen if VisualGDB could not display the normal project structure queried from CMake (normally it is cached and should not be lost).

    Would it be possible for you to create a quick video of this? If we could see the exact timing of the problem and the exact icons shown in Solution Explorer, we should be able to tell what is going on.

    #22963

    aronrubin
    Participant

    In this video I removed a line from a cpp file and saved.

    • This reply was modified 1 week, 6 days ago by  aronrubin.
    #22965

    aronrubin
    Participant

    I had to be real fast to be under the upload limit.

    • This reply was modified 1 week, 6 days ago by  aronrubin.
    Attachments:
    You must be logged in to view attached files.
    #22969

    aronrubin
    Participant

    Sorry it appears the mp4 video didn’t record correctly

    #22970

    support
    Keymaster

    Hi,

    Thanks for the video. It looks like when CMake updates the target list, the targets are reported in a different order (FaceServiceTest.exe gets in front of libFaceService.a) and hence the ‘expanded’ flag isn’t preserved properly. As a workaround, please set the “Sort targets by name” option via VS Project Properties (not VisualGDB Project Properties) -> Project Items->Sorting/Grouping.

    #22975

    aronrubin
    Participant

    Thank you. That seems to have worked.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.