ESP32 broken wifi driver?

Sysprogs forums Forums VisualGDB ESP32 broken wifi driver?

This topic contains 7 replies, has 2 voices, and was last updated by  JoeWright 1 week, 2 days ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #22232

    JoeWright
    Participant

    Hi, I haven’t dived into this much, but wondered if anyone else had noticed updating to the latest visualgdb version of the esp32 toolchain breaking the wifi?

    My wifi code was working fine but after updating, I’m getting lots of SYSTEM_EVENT_STA_DISCONNECTED events.

    There’s also differences in the debug text:

    old:

    wifi firmware version: b987c01
    phy_version: 3910, c0c45a3, May 21 2018, 18:07:06, 0, 0
    mode : sta (24:0a:c4:1e:03:28)

    new:

    wifi firmware version: 8c44f46
    phy_version: 4000, b6198fa, Sep  3 2018, 15:11:06, 0, 0
    mode : sta (24:0a:c4:1e:03:24)

    Thanks, Joe

    #22234

    support
    Keymaster

    Hi,

    Thanks for sharing the details. The Wi-Fi driver is included in the ESP-IDF itself (the ESP32 SDK provided by Espressif, the chip vendor) and does not come from us. Hence please consider creating a topic on the ESP32 forum, or simply downgrade to an ESP-IDF version (and/or toolchain) that works.

    #22236

    JoeWright
    Participant

    Ok, I will hit the esp32 forum and see if they have any thoughts.

    Meanwhile, I’ve tried to go back to rev. 12 of the toolchain but now my project is broken.  The project contents just say ‘Load failed, double-click for details’ (no details on double click), and if I try to clean or rebuild I get:

    —— Clean started: Project: Module01, Configuration: Debug VisualGDB ——
    VisualGDB: Run “c:\SysGCC\esp32\bin\bash.exe –login -c “export IDF_PATH=/esp-idf/v3.1 && export BATCH_BUILD=1 && export -n PYTHONHOME && export LANG=en_US && cd /E/projects/IMU/ESP32/Test_Projects/Module01 && make clean BUILD_DIR_BASE=’/E/projects/IMU/ESP32/Test_Projects/Module01/Debug’ SDKCONFIG=’/E/projects/IMU/ESP32/Test_Projects/Module01/sdkconfig-debug’ V=0″” in directory “” on local computer
    /usr/bin/bash: line 0: cd: /E/projects/IMU/ESP32/Test_Projects/Module01: No such file or directory
    ————————————————————-
    Command exited with code 1
    Executable: c:\SysGCC\esp32\bin\bash.exe
    Arguments: –login -c “export IDF_PATH=/esp-idf/v3.1 && export BATCH_BUILD=1 && export -n PYTHONHOME && export LANG=en_US && cd /E/projects/IMU/ESP32/Test_Projects/Module01 && make clean BUILD_DIR_BASE=’/E/projects/IMU/ESP32/Test_Projects/Module01/Debug’ SDKCONFIG=’/E/projects/IMU/ESP32/Test_Projects/Module01/sdkconfig-debug’ V=0”
    Directory:
    VisualGDB: Error: Command-line action failed
    ========== Clean: 0 succeeded, 1 failed, 0 skipped ==========

     

    I can access the visualgdb settings but I don’t know how to correct this corruption.  I’m finding I get a lot of project corruptions with upgrades/downgrades.  Any tips to correct?

    #22237

    support
    Keymaster

    Hi,

    Please try cleaning the project via Build->Clean All. If it doesn’t help, please remove the toolchain completely and install it again via VisualGDB Package Manager.

    It should get rid of any conflicting files and get the project to build again.

    #22239

    JoeWright
    Participant

    Unfortunately the output I posted above is what happens when you do a Clean Solution, and uninstalling and reinstalling the toolchain made no difference.

    #22240

    JoeWright
    Participant

    I’ve tried downgrading to preview 4, to get back to where I was, but still no joy.  Also, all of my esp32 projects now won’t load properly, clean, etc…

    #22244

    support
    Keymaster

    Hi,

    No problem, we will help you get it to work. The problem could be caused by 2 issues: a corrupt toolchain, or incompatible settings cached in the projects.

    Please try installing the R12 toolchain and VisualGDB 5.4 Preview 6. Then try creating a new project. If it builds works, please open one of the old projects and check the VisualGDB Project Properties -> Path Mapping -> GDB Path Style setting. It should be set to “Use toolchain default”.

    If the old projects still don’t work, please try comparing the .vgdbproj files in a diffing tool (e.g. KDiff3) or simply import the old projects via the ESP32 project wizard to regenerate the settings file.

    #22272

    JoeWright
    Participant

    Thanks, the path mapping did the trick.  I didn’t really make any changes, just clicked manual then back to default and that was enough to reset it back to normal.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.