debug PHP extension

Sysprogs forums Forums VisualGDB debug PHP extension

This topic contains 7 replies, has 2 voices, and was last updated by  support 4 months, 1 week ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #9983

    amigo421
    Participant

    hi

    host : win10, target Debian

    developing PHP extension, so the debug settings are:

    application: php

    parameter: myscript.php

     

    php ini and extension location looks specified correctly,

    because I see its diagnostic console output in gdb log, however breakpoint doesn’t catch the runflow.

    any idea what can be wrong?

    #9984

    support
    Keymaster

    Hi,

    This looks like some kind of a symbol load problem. Please check if gdb shows your plugin in the ‘info symbols’ command output. If yes, please try adding the path to the .so file with symbols via the set solib-search path command so that gdb can load symbols for it.

    #10006

    amigo421
    Participant

    didn’t find ” info symbols” output… please assist

     

    by the way , a couple more questions:

    1. in a wizard “import .so project”, that I’m doing from linux host, the setting: Debugged executable , I’m specifying “php”, however, after the project created, this field is $(TargetPath), and I need to change this again, is it a bug?
    2. please clarify, why my makefile from linux host is not imported locally? If I will download this manually and change this locally, will this be uploaded to remote host for a building automatically?
    #10010

    amigo421
    Participant

    do I understand GCC compilation right , for the including debug info, I have to add these flags to Makefile

    LD_FLAGS = -Wall -shared -O0 –g -ggdb3  ??

     

    and how can I add “set solib-search path command”? and why? all my sources and .so in the same work directory (just for simplifying on this step)

    • This reply was modified 4 months, 2 weeks ago by  amigo421.
    #10013

    amigo421
    Participant

    the topic can be closed,

    the steps to solve:

    1. after makefile-based project import, build system has been set to Custom, so I’ve changed to GNU Make manually. is it okay? or bug?
    2. add some required (from makefile GUI dialog) settings, which were added to my existing makefile, thanks a lot that just added only, not overwritten 🙂

    the settings from default Debug GUI dialog were enough for start debug

    currently works perfect, thank you!

    =========================================================================

    so as a summary of the topic:

    1. please confirm that Debugged Executable is not stored to settings when specified in a Wizard, bug?
    2. IMport makefile based project doesn’t set build system to GNU Make, why
    • This reply was modified 4 months, 2 weeks ago by  amigo421.
    #10028

    support
    Keymaster

    Hi,

    Good to know it works.

    The ‘custom’ build system is used for projects where VisualGDB does not control the Makefile structure and cannot do precisely aimed edits to it. This is always the case when you import an external project (as the Makefile was not generated by VisualGDB). The only practical difference is that you would need to synchronize IntelliSense settings manually and edit the Makefiles directly instead of the VisualGDB GUI.

    When you switch to the regular GNU Make subsystem, VisualGDB regenerates the Makefile based on its own template and will know how to edit it based on the settings from GUI. Although this is easier to handle, it will replace any custom steps present in the original Makefile, so VisualGDB does not to this unless explicitly requested.

    #10044

    amigo421
    Participant

    thank you, I successfully switched on GNU Make system, with some limits (see my topic about custom build folder)

    please comment my question about debugged executeable field.

    1. please confirm that Debugged Executable is not stored to settings when specified in a Wizard, bug?

    if this is really a bug, do you have a public tracker for the requests?

    #10049

    support
    Keymaster

    Hi,

    The debugged executable should be stored in settings when importing projects (under Build Settings -> Main binary). If this does not happen, please let us know the exact steps to reproduce this so that we could help you.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.