SmarTTY "Passphrase Required" Error

Sysprogs forums Forums Other tools & products SmarTTY "Passphrase Required" Error

This topic contains 6 replies, has 7 voices, and was last updated by  marco2021 1 month, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #13095

    qq
    Participant

    Hello,

    I am currently searching for alternatives to Putty on a Windows computer. In order to test SmarTTY, I used the PuttyGen-Tool to convert the key files into the open ssh private key format (rsa 2048 bit). The key file is password protected, the PuttyGen tool is able to import it again using the passphrase. In SmarTTY, I want to connect to my debian server using the public key authentication method. Since I am using different keys per machine, I am configuring an alternative key location. Since the key file contains an encrypted key, I enter a passphrase, and yet, I get the error message “Passphrase Required”. How can I solve this?

    Thanks, in advance

    #20152

    wcatlan
    Participant

    I am experiencing the same error with the same scenario. Kindly share any resolution. Thanks!

    #20374

    warlord0
    Participant

    Same issue. But to resolve it I had to place the id_rsa under my windows profile eg. c:\users\warlord0\.ssh\id_rsa and even then set it with no password.

    #20685

    Chuxter
    Participant

    I have the same exact problem.

    It’s surprising that months have gone by and the devs haven’t fixed it. Actually, perhaps this has been broken since 2016.

    See topic:  https://sysprogs.com/w/forums/topic/ssh-cannot-connect-passphrase-required/

    I won’t be using SmarTTY, as it is not very smart….

    #21376

    mbalsam
    Participant

    I agree, pathetic this has not been fixed.. What are alteratives to SmartTTY?

     

    #21482

    flynnjs
    Participant

    Would like to add that SmarTTY 3.1 (built into latest version of VisualGDB) still not working with keys which have a passphrase. Total showstopper.

    #31845

    marco2021
    Participant

    The Solution is to save the generated key in another format.

    After generating the key click in PuTTY Key Generator on Conversions and then choose Export OpenSSH key.

    Save the private key as “id_rsa” for example.

    Then use this File within SmarTTY to log in on your server using your chosen password.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.