NRFConnect SDK from nordic Nordic v 2.4.1 and 2.4.2, unable to install.

Sysprogs forums Forums VisualGDB NRFConnect SDK from nordic Nordic v 2.4.1 and 2.4.2, unable to install.

This topic contains 2 replies, has 2 voices, and was last updated by  Manuel Elko 5 days, 23 hours ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #34689

    Manuel Elko
    Participant

    As per Title.

    take care,

    Manuel.

    #34745

    support
    Keymaster

    Hi,

    Sorry for the delay. We have investigated this and it turns out NRFConnect 2.4+ requires a newer version of Python (we tested 3.11.5 and it worked). However, older NRFConnect versions, and some other frameworks used by VisualGDB are not compatible with Python 3.11 and require older versions (3.8 works).

    We have updated VisualGDB to keep separate track of several Python installations and pick them based on the project type and the SDK version.

    Please try installing this build [VisualGDB-6.0.2.4929.msi] and updating the package catalog via Tools->VisualGDB->Manage VisualGDB Packages->Online. It should fetch the correct package definitions and pick the correct Python package compatible with the NRFConnect version you are using.

    #34760

    Manuel Elko
    Participant

    Dear Support Team,

    I confirm the reached functionality covered with v6.0.2.4929 (object of this post).

    thank you for actively supporting & take care,

    Manuel.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.