Kernel 2.4.x supporting

Sysprogs forums Forums VisualKernel Kernel 2.4.x supporting

This topic contains 3 replies, has 2 voices, and was last updated by  support 1 year, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #21736

    le
    Participant

    Hi. Do you support old kernels such a 2.4 and earlier?

    #21740

    support
    Keymaster

    Hi,

    Sorry, we don’t support older kernels officially as they are missing many APIs required by various parts of VisualKernel (e.g. our Ethernet debugging driver and the fast module enumeration driver). As we provide source code for both of those components, you might be able to patch them to run under older kernels, but we won’t be officially supporting the 2.4 kernel as it is no longer actively maintained and not used in modern distros.

    #21745

    le
    Participant

    Oh. Do you know maybe any technique for easy debugging of that kernels?
    Thanks.

    #21750

    support
    Keymaster

    Hi,

    Sorry, unfortunately not much. As this kernel version was discontinued ~7 years ago, most modern tools will likely not support it anymore, so we would advise switching to a newer system that runs a 3.x or a 4.x kernel.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.