Help on JLink GDB server Connection Fail

Sysprogs forums Forums VisualGDB Help on JLink GDB server Connection Fail

This topic contains 4 replies, has 2 voices, and was last updated by  tman2018 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #33238

    tman2018
    Participant

    Hi There,

    Having a issue for connecting JLink GDB server! Help please!

    The log info from GDB stub log:

    =============================================================

    C:\Program Files\SEGGER\JLink_v780a\JLinkGDBServerCL.exe -select USB -device NUC029LEE -speed 33000 -if SWD -port 50692
    SEGGER J-Link GDB Server V7.80a Command Line Version

    JLinkARM.dll V7.80a (DLL compiled Sep 14 2022 15:42:42)

    Command line: -select USB -device NUC029LEE -speed 33000 -if SWD -port 50692
    —–GDB Server start settings—–
    GDBInit file: none
    GDB Server Listening port: 50692
    SWO raw output listening port: 2332
    Terminal I/O port: 2333
    Accept remote connection: localhost only
    Generate logfile: off
    Verify download: off
    Init regs on start: off
    Silent mode: off
    Single run mode: off
    Target connection timeout: 0 ms
    ——J-Link related settings——
    J-Link Host interface: USB
    J-Link script: none
    J-Link settings file: none
    ——Target related settings——
    Target device: NUC029LEE
    Target device parameters: none
    Target interface: SWD
    Target interface speed: 33000kHz
    Target endian: little

    Connecting to J-Link…
    J-Link is connected.
    Firmware: J-Link Pro V4 compiled Sep 24 2021 16:41:59
    Hardware: V4.00
    S/N: 174504218
    Feature(s): RDI, FlashBP, FlashDL, JFlash, GDB
    Checking target voltage…
    Target voltage: 3.33 V
    Listening on TCP/IP port 50692
    Connecting to target…
    Connected to target
    Waiting for GDB connection…Connected to 127.0.0.1
    GDB closed TCP/IP connection (Socket 948)

    =============================================================

     

     

    #33243

    support
    Keymaster

    Hi,

    It looks like gdb manages to connect to J-Link and then disconnects. Please try collecting and analyzing the GDB log as shown here: https://visualgdb.com/support/logsubmit

    #33257

    tman2018
    Participant

    Hi,

    Here is the logged info, advise please! Thanks!

    ====================================================

    C:\Program Files (x86)\Sysprogs\VisualGDB\Keil\arm-none-eabi-gdb.exe –interpreter mi “D:\@coding\@bce\ap8557cdma\_AP8557x1.0828t191Bx0821V2(REV)_220118R0_Lib\.project\vgdb\AP8557V2REV\VisualGDB\Debug\AP8557V2REV.elf”
    [ 0 ms] -gdb-version
    [ 42 ms] C:\Program Files (x86)\Sysprogs\VisualGDB\Keil\arm-none-eabi-gdb.exe: warning: Couldn’t determine a path for the index cache directory.
    [ 70 ms] =thread-group-added,id=”i1″
    [ 70 ms] ~”GNU gdb (GDB) 9.2\n”
    [ 70 ms] ~”Copyright (C) 2020 Free Software Foundation, Inc.\n”
    [ 70 ms] ~”License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html&gt;\nThis is free software: you are free to change and redistribute it.\nThere is NO WARRANTY, to the extent permitted by law.”
    [ 70 ms] ~”\nType \”show copying\” and \”show warranty\” for details.\n”
    [ 70 ms] ~”This GDB was configured as \”–host=i686-w64-mingw32 –target=arm-none-eabi\”.\n”
    [ 70 ms] ~”Type \”show configuration\” for configuration details.\n”
    [ 70 ms] ~”For bug reporting instructions, please see:\n”
    [ 70 ms] ~”<http://www.gnu.org/software/gdb/bugs/&gt;.\n”
    [ 71 ms] ~”Find the GDB manual and other documentation resources online at:\n <http://www.gnu.org/software/gdb/documentation/&gt;.”
    [ 71 ms] ~”\n\n”
    [ 71 ms] ~”For help, type \”help\”.\n”
    [ 71 ms] ~”Type \”apropos word\” to search for commands related to \”word\”…\n”
    [ 76 ms] ~”Reading symbols from D:\\@coding\\@bce\\ap8557cdma\\_AP8557x1.0828t191Bx0821V2(REV)_220118R0_Lib\\.project\\vgdb\\AP8557V2REV\\VisualGDB\\Debug\\AP8557V2REV.elf…\n”
    [ 96 ms] ~”GNU gdb (GDB) 9.2\n”
    [ 96 ms] ~”Copyright (C) 2020 Free Software Foundation, Inc.\n”
    [ 96 ms] ~”License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html&gt;\nThis is free software: you are free to change and redistribute it.\nThere is NO WARRANTY, to the extent permitted by law.”
    [ 96 ms] ~”\nType \”show copying\” and \”show warranty\” for details.\n”
    [ 97 ms] ~”This GDB was configured as \”–host=i686-w64-mingw32 –target=arm-none-eabi\”.\n”
    [ 97 ms] ~”Type \”show configuration\” for configuration details.\n”
    [ 97 ms] ~”For bug reporting instructions, please see:\n”
    [ 97 ms] ~”<http://www.gnu.org/software/gdb/bugs/&gt;.\n”
    [ 97 ms] ~”Find the GDB manual and other documentation resources online at:\n <http://www.gnu.org/software/gdb/documentation/&gt;.”
    [ 97 ms] ~”\n\n”
    [ 97 ms] ~”For help, type \”help\”.\n”
    [ 97 ms] ~”Type \”apropos word\” to search for commands related to \”word\”.\n”
    [ 97 ms] ^done
    [ 97 ms] -list-features
    [ 113 ms] ~”Exception condition detected on fd -1\n”
    [ 114 ms] ^done,features=[“frozen-varobjs”,”pending-breakpoints”,”thread-info”,”data-read-memory-bytes”,”breakpoint-notifications”,”ada-task-info”,”language-option”,”info-gdb-mi-command”,”undefined-command-error-code”,”exec-run-start-option”,”data-disassemble-a-option”]
    [ 114 ms] -gdb-set verbose on
    [ 129 ms] ~”Exception condition detected on fd -1\n”
    [ 129 ms] ^done
    [ 130 ms] -gdb-set disassembly-flavor intel
    [ 131 ms] ~”Exception condition detected on fd -1\n”
    [ 132 ms] ^error,msg=”No symbol \”disassembly\” in current context.”
    [ 132 ms] -gdb-set print demangle off
    [ 132 ms] ~”Exception condition detected on fd -1\n”
    [ 133 ms] ^done
    [ 134 ms] target remote :51007
    [ 143 ms] ~”Exception condition detected on fd -1\n”
    [ 143 ms] &”target remote :51007\n”
    [ 2226 ms] ~”Remote debugging using :51007\n”
    [ 10788 ms] &”Quit\n”
    [ 10788 ms] ^error,msg=”Quit”

    ====================================================

    Attachments:
    You must be logged in to view attached files.
    #33259

    support
    Keymaster

    Thanks, it looks like gdb never reports a successful connection to the J-Link GDB server. Please try running both of them manually:

    and gdb:

    Does it result in a successful debugging session? If not, please try disabling your firewall/antivirus and using a different port number.

    #33269

    tman2018
    Participant

    Hi,

    Thanks for prompt reply! Would give it a try!

     

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.