Clang IntelliSense auto complete not always showing up

Sysprogs forums Forums VisualGDB Clang IntelliSense auto complete not always showing up

This topic contains 4 replies, has 2 voices, and was last updated by  support 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #24249

    MystikReasons
    Participant

    Is there an option to enable the auto complete to always show up?

    My problem right now is that it only shows up when I write something like that (foo->…) but not if I’m writing the word “foo”.

     

    I really like what you did with the autocomplete (my example: foo->pressiure) and if I backspace until “press” it automatically comes back again and shows “pressure”.

    Would it be possible to implement this also for my question above if its not already inside?

    I’m using Visual Studio 2019 Preview 4.2 with VisualGDB build 3009

    #24251

    MystikReasons
    Participant

    Update: I found the option that the clang intellisense is always showing up (“Suggest name as you type them”).

    You can ignore my two questions above.

    But my new question: I had to write “exp: foo->” so I can see the window and make adjustments. Is there another window where I can edit those options?

    If not would it be possible to add those options inside the “VisualGDB project properties” under the IntelliSense Settings?

    This would be in my opinion the first place if you search for options for the intellisense

     

    PS: You did an amazing job with the intellisense, I really like it. Props on you! 😉

    #24265

    support
    Keymaster

    The suggestions are automatically derived from scanning the code and cannot be adjusted. If you believe they are not working as expected and can reproduce it on a project that otherwise builds successfully, please share the repro steps and we will investigate.

    #24278

    MystikReasons
    Participant

    I think you didn’t read my second post or you misunderstood it.

    My question was about the intellisense window with their options at the bottom showing up for auto complete suggestions:

    If you have deactivated the thunderbolt symbol “Suggest names as you type them” then it’s difficult to get to those options for the intellisense window (see screenshot #1) because it won’t show up normally.

    I had to do something like this to even get the window up: bm280-> first then the window showed up and at this point I could change those options (inside the autocomplete window).

    Would it be possible to add these options under the IntelliSense Settings window of the VisualGDB Project Properties too?

    This would be in my opinion the first place if you search for options for the intellisense.

     

    Attachments:
    You must be logged in to view attached files.
    #24301

    support
    Keymaster

    Thanks for the clarification. There is already an option for this under Tools->Options->Text Editor->C/C++ (VisualGDB)->Advanced->Code Completion->Suggest names while typing.

    If the option is disabled, you can invoke the suggestion menu explicitly via Edit->IntelliSense->Complete Word command (Ctrl-Space) which is standard for all Visual Studio project types.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.