Attach to Process: "Don't stop the process after attaching" by default?

Sysprogs forums Forums VisualGDB Attach to Process: "Don't stop the process after attaching" by default?

Tagged: 

This topic contains 6 replies, has 2 voices, and was last updated by  MiloDC 2 months, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #23354

    MiloDC
    Participant

    In the “Attach to Process” window, how do I enable the “nostop” feature by default?

    I always have to click “Find…” and then set the option manually.  I’d much rather just have “,nostop” always appended to the connection target.

     

    VisualGDB nostop

    • This topic was modified 2 months, 1 week ago by  MiloDC.
    #23356

    support
    Keymaster

    Hi,

    Do you use the “Find” button to find the target? If yes, we could make it remember the last state of the flags for each target.

    #23357

    MiloDC
    Participant

    No, sometimes I’ll just append “,nostop” directly to the connection target field, after selecting a target in the drop-down.

    I should be able to specify “nostop” as a property on the connection targets themselves (e.g. in the SSH Host Manager).

     

    • This reply was modified 2 months, 1 week ago by  MiloDC.
    • This reply was modified 2 months, 1 week ago by  MiloDC.
    #23367

    support
    Keymaster

    Hi,

    No problem. Please try this build: http://sysprogs.com/files/tmp/VisualGDB-5.4.100.2728.msi

    It will remember the last used host selected via the “Find” button and the “nostop” flag. You will be also able to add/remove the “,nostop” part manually just as before.

    #23459

    MiloDC
    Participant

    Doesn’t work.  When I reopen the Attach to Process window, there’s still no option in the “Connection target” drop-down that’s appended with “,nostop.”  I still have to add the option manually (either by typing it, or by opening the “Find…” window and clicking the option box).

     

    Also, how do I hide/turn off the reference links above my functions/methods?

     

    #23464

    support
    Keymaster

    Please try enabling the option in the “Find” window and then restart Visual Studio. Next time you start it, “nostop” will be automatically added to all entries in the target list.

    You can disable the CodeJumps references by clicking at the tag button in the top right corner of the screen.

    #23469

    MiloDC
    Participant

    Please try enabling the option in the “Find” window and then restart Visual Studio. Next time you start it, “nostop” will be automatically added to all entries in the target list.

    Success!  Thank you for the superb customer service!

    You can disable the CodeJumps references by clicking at the tag button in the top right corner of the screen.

    Again, thanks!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.