Kenzi

Forum Replies Created

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts

  • Kenzi
    Participant

    That was it.  I had to restart Visual Studio.  Then regenerating worked.

    Thanks.


    Kenzi
    Participant

    As a workaround, please try moving the BSP into a directory with a shorter path (e.g. c:\NordicBSP) and then create a .bsplink file instead of the original directory (e.g. %LOCALAPPDATA%\VisualGDB\EmbeddedBSPs\arm-eabi\com.sysprogs.arm.nordic.nrf5x.bsplink) that will contain the full path to the new short directory.

    I did this, and it cleared up the issue mostly.  Under VisualGDB Project Properties -> Embedded Project, the Shared files location now shows C:\NordicBSP.  However, the files generated under my project’s Device-specific files still all point to C:\Users\kenzi\AppData\Local\VisualGDB\EmbeddedBSPs\arm-eabi\com.sysprogs.arm.nordic.nrf5x\.  It builds fine (somehow?), but CLang is totally broken now.

    I have tried a few things, but I just can’t convince VisualGDB to generate solution files that point to the proper location.  Any ideas?

     


    Kenzi
    Participant

    Never paid much attention.  It’s what was installed with VisualGDB.. but now “ARM” isn’t even in the VisualGDB package list… does this mean I should install it as an extern toolchain?

    (edit: oops I didn’t see who made that last reply)

    • This reply was modified 1 month, 1 week ago by  Kenzi.

    Kenzi
    Participant

    VisualGDB is acting strange as far as the ARM toolchain install/uninstall.

    No ARM toolchains appear in the “Manage VisualGDB Packages” list unless I check “Show old packages.”  Still, the current toolchain I’m using (GCC 2.7.0 GDB 8.0.1) isn’t in the package list.  This toolchain does show up in the MSBuild settings -> Toolchain dropdown.  I’ve uninstalled and reinstalled using that dropdown.  The reinstall seemed to mostly work, but it still only builds only if I have a <32KB command line.

     

    • This reply was modified 1 month, 1 week ago by  Kenzi.

    Kenzi
    Participant

    Okay, I hope I did this right – it was installed with VisualGDB, so I unstalled it and VisualGDB prompted me to reinstall it.

    Executing this command:

    Yielded basically the same result.  I’m not sure how to capture it all, but it started with this:

    That last line was probably about 32KB long.

    And it ended like this:

    So it looks like gcc itself is struggling with the long line?


    Kenzi
    Participant

    The command line is being shown because I set msbuild output to Detailed.  I will upload to the support form.

     


    Kenzi
    Participant

    I thought I was using MSBuild, unless I’m misunderstanding these settings.

    Attachments:
    You must be logged in to view attached files.
Viewing 7 posts - 1 through 7 (of 7 total)