Why don't the tutorials work?? ESP_ADF

Sysprogs forums Forums VisualGDB Why don't the tutorials work?? ESP_ADF

This topic contains 16 replies, has 3 voices, and was last updated by  orbitcoms 1 week, 1 day ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #30746

    orbitcoms
    Participant

    I have followed along for creating an ESP-ADF project from the tutorial precisely and keep getting error as below.

    Have submitted to “support” but have been advised this will take several weeks to look at. I cannot put off my project for several weeks because it needs delivery to customer soon.

    I selected latest version of adf to clone and then also tried same version 1.0 as the tutorial.

    Severity Description Project File Line
    Error Failed to start process (C:\SysGCC\esp32\usr\bin\bash.exe –login -c “export ADF_PATH=/esp-adf/v1.0 && export BATCH_BUILD=1 && export PATH=/tools/xtensa-esp32-elf/esp-2020r3-8.4.0/xtensa-esp32-elf/bin:/tools/xtensa-esp32s2-elf/esp-2020r3-8.4.0/xtensa-esp32s2-elf/bin:/tools/esp32ulp-elf/2.28.51-esp-20191205/esp32ulp-elf-binutils/bin:/tools/esp32s2ulp-elf/2.28.51-esp-20191205/esp32s2ulp-elf-binutils/bin:/tools/idf-exe/1.0.1:/tools/ccache/3.7:/tools/ninja/1.10.0:$PATH && export -n PYTHONHOME && export LANG=en_US && cd /c/projects/ESPADFDemo && make defconfig BUILD_DIR_BASE=’/c/projects/ESPADFDemo/.visualgdb/VisualGDBCache/ESPADFDemo-Debug-VisualGDB/CodeSenseDir’ SDKCONFIG=’/c/projects/ESPADFDemo/sdkconfig-debug’ V=0”): The system cannot find the file specified ESPADFDemo 1

    Severity Description Project File Line
    Error Could not find file ‘c:\projects\ESPADFDemo\sdkconfig-debug’. ESPADFDemo

     

    #30748

    support
    Keymaster

    Hi,

    Please note that Espressif often changes the internal structure of their frameworks. They often break compatibility with older toolchains, or specific examples. Our support is not able to take over the maintenance and testing of their products, or provide personalized insights into their internal structure. We can only make sure that as long as the ESP-IDF-based project can be built and works otherwise, you will be able to use the VisualGDB GUI to conveniently edit it, instead of manually editing various configuration files.

    If you are not able to build the project at all (even outside VisualGDB), please contact Espressif for further help.

    #30749

    orbitcoms
    Participant

    I am learning just how much of the great Visual GDB support does not cover and less about what is covered. A disclaimer on the tutorials would be helpful like “these steps worked for us but they probably won’t work for you because esp-idf and adf frameworks keep changing and we advise you follow along with espressif command line setup and testing before attempting to use the tools in a gdb project.

    So, You are saying that I should be using other tools (Not visual studio and visual gdb) to create and test my projects first to make sure they work before attempting to run them using gdb?

    And, that the “cloning” step in the adf project does not actually install adf framework. What does the “cloning” for esp sdk adf project do?

    Also, I do not see how to select the esp-idf version to use in the new adf project based on your tutorial. When you “clone” (whatever that does) the adf, I cannot see a selection for which version of esp-idf to use.

    So, I need to install multiple versions of esp-idf and adf on my machine so they are available in Visual gdb. Then somehow select esp-idf version 4.1 (the one you state is tested to work with adf).

     

    #30750

    support
    Keymaster

    If you are using the same version of the tools and frameworks that are shown in our tutorial, it should work the same way.

    If you are using a different version, it may indeed work differently, because it is a different version. We do not charge our users each time a new ESP-IDF framework is released, hence we are not able to guarantee that every ESP-IDF version will work exactly the same.

    We do test the new releases and update our tutorials periodically, however we prioritize this based on the amount of affected users. The ESP-ADF framework is specific to audio devices, has a relatively small number of users, and is hence a lower priority.

    #30751

    orbitcoms
    Participant

    How do I select which esp-idf framework to use when creating the same project as in the tutorial?

    You used version esp-idf 4.1 with v1.0 adf-framework.

    I selected V1.0 framework for adf, but which version of esp-idf is being used? I cannot see where to select it.

    The files it cannot load are attemting to be loaded from the SysCGG folder that is created by Visual GDB.

    Attachments:
    You must be logged in to view attached files.
    #30759

    orbitcoms
    Participant

    I have been able to get all my projects running in VS with visual studio except 1 project using ADF.

    I can confirm the ADF project DOES compile and run ok in VS Code using ESP-IDF and ADF framework but does not run with Visual Studio and GDB.

    It runs with both ESP-IDF 4.2 and the latest 4.3 and ADF V2.3 ok in VS CODE.

    So, the frame work and compiler tools/versions are not the problem.

    #30793

    support
    Keymaster

    Hi,

    We have just rechecked the latest ESP-ADF framework. Just as our tutorial mentions, it doesn’t work with the latest GCC 8.x, but does work if you install GCC 5.2.0. This happens because ESP-ADF is based on an older ESP-IDF, that expects that specific old compiler version. Most likely, you ended up using GCC 5.2.0 with VS Code and GCC 8.x with VisualGDB.

    Please double-check your GCC versions in the toolchain selection drop-down and make sure you are using GCC 5.2.0 with ESP-ADF as explained in the tutorial.

    #30794

    orbitcoms
    Participant

    Where do I find the GCC selection drop-down please?

    #30796

    support
    Keymaster

    Please follow the tutorials.

    #30797

    orbitcoms
    Participant

    Thank you. I can create a new project and it compiles now.

    However, when I try to create a new project using my existing code, it fails to load.

     

    This is the build output I see.

     

    Running CMake: C:\Users\david\AppData\Local\VisualGDB\CMake\bin\cmake.exe ../../.. -G “Ninja” -DCMAKE_BUILD_TYPE=DEBUG -DCMAKE_MAKE_PROGRAM=”C:/Program Files (x86)/Sysprogs/VisualGDB/ninja.exe”
    fatal: not a git repository (or any of the parent directories): .git
    — Checking Python dependencies…
    Python requirements from C:/SysGCC/esp32/esp-idf/v3.2\requirements.txt are satisfied.
    CMake Warning at C:/SysGCC/esp32/esp-idf/v3.2/tools/cmake/scripts/expand_requirements.cmake:94 (message):
    Required component espcoredump is not found in any of the provided
    COMPONENT_DIRS
    Call Stack (most recent call first):
    C:/SysGCC/esp32/esp-idf/v3.2/tools/cmake/scripts/expand_requirements.cmake:164 (find_component_path)
    C:/SysGCC/esp32/esp-idf/v3.2/tools/cmake/scripts/expand_requirements.cmake:183 (expand_component_requirements)
    C:/SysGCC/esp32/esp-idf/v3.2/tools/cmake/scripts/expand_requirements.cmake:183 (expand_component_requirements)
    C:/SysGCC/esp32/esp-idf/v3.2/tools/cmake/scripts/expand_requirements.cmake:286 (expand_component_requirements)

    — Building empty aws_iot component due to configuration
    — Component names: soc log heap xtensa-debug-module app_trace freertos vfs newlib esp_ringbuf driver esp_event ethernet lwip tcpip_adapter partition_table app_update spi_flash mbedtls micro-ecc bootloader_support nvs_flash pthread smartconfig_ack wpa_supplicant esp32 cxx audio_sal esp_adc_cal wear_levelling sdmmc fatfs console esp-sr nghttp esp-tls tcp_transport esp-adf-libs audio_pipeline spiffs display_service esp_dispatcher bt esp_peripherals audio_board audio_hal my_board esp_http_client jsmn adf_utils wifi_service clouds dueros_service esp_actions tone_partition audio_stream battery_service bluetooth_service espcoredump coredump_upload_service esp_event_cast input_key_service esp_https_ota ota_service playlist asio aws_iot bootloader coap esp_http_server esptool_py expat freemodbus idf_test json libsodium mdns mqtt openssl protobuf-c protocomm ulp wifi_provisioning main
    — Component paths: C:/SysGCC/esp32/esp-idf/v3.2/components/soc;C:/SysGCC/esp32/esp-idf/v3.2/components/log;C:/SysGCC/esp32/esp-idf/v3.2/components/heap;C:/SysGCC/esp32/esp-idf/v3.2/components/xtensa-debug-module;C:/SysGCC/esp32/esp-idf/v3.2/components/app_trace;C:/SysGCC/esp32/esp-idf/v3.2/components/freertos;C:/SysGCC/esp32/esp-idf/v3.2/components/vfs;C:/SysGCC/esp32/esp-idf/v3.2/components/newlib;C:/SysGCC/esp32/esp-idf/v3.2/components/esp_ringbuf;C:/SysGCC/esp32/esp-idf/v3.2/components/driver;C:/SysGCC/esp32/esp-idf/v3.2/components/esp_event;C:/SysGCC/esp32/esp-idf/v3.2/components/ethernet;C:/SysGCC/esp32/esp-idf/v3.2/components/lwip;C:/SysGCC/esp32/esp-idf/v3.2/components/tcpip_adapter;C:/SysGCC/esp32/esp-idf/v3.2/components/partition_table;C:/SysGCC/esp32/esp-idf/v3.2/components/app_update;C:/SysGCC/esp32/esp-idf/v3.2/components/spi_flash;C:/SysGCC/esp32/esp-idf/v3.2/components/mbedtls;C:/SysGCC/esp32/esp-idf/v3.2/components/micro-ecc;C:/SysGCC/esp32/esp-idf/v3.2/components/bootloader_support;C:/SysGCC/esp32/esp-idf/v3.2/components/nvs_flash;C:/SysGCC/esp32/esp-idf/v3.2/components/pthread;C:/SysGCC/esp32/esp-idf/v3.2/components/smartconfig_ack;C:/SysGCC/esp32/esp-idf/v3.2/components/wpa_supplicant;C:/SysGCC/esp32/esp-idf/v3.2/components/esp32;C:/SysGCC/esp32/esp-idf/v3.2/components/cxx;C:/esp/esp-adf-v2.3/components/audio_sal;C:/SysGCC/esp32/esp-idf/v3.2/components/esp_adc_cal;C:/SysGCC/esp32/esp-idf/v3.2/components/wear_levelling;C:/SysGCC/esp32/esp-idf/v3.2/components/sdmmc;C:/SysGCC/esp32/esp-idf/v3.2/components/fatfs;C:/SysGCC/esp32/esp-idf/v3.2/components/console;C:/esp/esp-adf-v2.3/components/esp-sr;C:/SysGCC/esp32/esp-idf/v3.2/components/nghttp;C:/SysGCC/esp32/esp-idf/v3.2/components/esp-tls;C:/SysGCC/esp32/esp-idf/v3.2/components/tcp_transport;C:/esp/esp-adf-v2.3/components/esp-adf-libs;C:/esp/esp-adf-v2.3/components/audio_pipeline;C:/SysGCC/esp32/esp-idf/v3.2/components/spiffs;C:/esp/esp-adf-v2.3/components/display_service;C:/esp/esp-adf-v2.3/components/esp_dispatcher;C:/SysGCC/esp32/esp-idf/v3.2/components/bt;C:/esp/esp-adf-v2.3/components/esp_peripherals;C:/esp/esp-adf-v2.3/components/audio_board;C:/esp/esp-adf-v2.3/components/audio_hal;C:/projects/CAB_ROLEC_ESP_PCB0325_G/components/my_board;C:/SysGCC/esp32/esp-idf/v3.2/components/esp_http_client;C:/SysGCC/esp32/esp-idf/v3.2/components/jsmn;C:/esp/esp-adf-v2.3/components/adf_utils;C:/esp/esp-adf-v2.3/components/wifi_service;C:/esp/esp-adf-v2.3/components/clouds;C:/esp/esp-adf-v2.3/components/dueros_service;C:/esp/esp-adf-v2.3/components/esp_actions;C:/esp/esp-adf-v2.3/components/tone_partition;C:/esp/esp-adf-v2.3/components/audio_stream;C:/esp/esp-adf-v2.3/components/battery_service;C:/esp/esp-adf-v2.3/components/bluetooth_service;C:/esp/esp-adf-v2.3/components/coredump_upload_service;C:/esp/esp-adf-v2.3/components/coredump_upload_service;C:/esp/esp-adf-v2.3/components/esp_event_cast;C:/esp/esp-adf-v2.3/components/input_key_service;C:/SysGCC/esp32/esp-idf/v3.2/components/esp_https_ota;C:/esp/esp-adf-v2.3/components/ota_service;C:/esp/esp-adf-v2.3/components/playlist;C:/SysGCC/esp32/esp-idf/v3.2/components/asio;C:/SysGCC/esp32/esp-idf/v3.2/components/aws_iot;C:/SysGCC/esp32/esp-idf/v3.2/components/bootloader;C:/SysGCC/esp32/esp-idf/v3.2/components/coap;C:/SysGCC/esp32/esp-idf/v3.2/components/esp_http_server;C:/SysGCC/esp32/esp-idf/v3.2/components/esptool_py;C:/SysGCC/esp32/esp-idf/v3.2/components/expat;C:/SysGCC/esp32/esp-idf/v3.2/components/freemodbus;C:/SysGCC/esp32/esp-idf/v3.2/components/idf_test;C:/SysGCC/esp32/esp-idf/v3.2/components/json;C:/SysGCC/esp32/esp-idf/v3.2/components/libsodium;C:/SysGCC/esp32/esp-idf/v3.2/components/mdns;C:/SysGCC/esp32/esp-idf/v3.2/components/mqtt;C:/SysGCC/esp32/esp-idf/v3.2/components/openssl;C:/SysGCC/esp32/esp-idf/v3.2/components/protobuf-c;C:/SysGCC/esp32/esp-idf/v3.2/components/protocomm;C:/SysGCC/esp32/esp-idf/v3.2/components/ulp;C:/SysGCC/esp32/esp-idf/v3.2/components/wifi_provisioning;C:/projects/CAB_ROLEC_ESP_PCB0325_G/main
    warning: ignored attempt to assign user value to IDF_CMAKE, which gets its value from the environment
    — Adding linker script C:/projects/CAB_ROLEC_ESP_PCB0325_G/build/VisualGDB/Debug/esp32/esp32_out.ld
    — Adding linker script C:/SysGCC/esp32/esp-idf/v3.2/components/esp32/ld/esp32.common.ld
    — Adding linker script C:/SysGCC/esp32/esp-idf/v3.2/components/esp32/ld/esp32.rom.ld
    — Adding linker script C:/SysGCC/esp32/esp-idf/v3.2/components/esp32/ld/esp32.peripherals.ld
    — Adding linker script C:/SysGCC/esp32/esp-idf/v3.2/components/esp32/ld/esp32.rom.libgcc.ld
    — Adding linker script C:/SysGCC/esp32/esp-idf/v3.2/components/esp32/ld/esp32.rom.spiram_incompatible_fns.ld
    CMake Error at C:/esp/esp-adf-v2.3/components/esp-sr/CMakeLists.txt:16 (target_link_libraries):
    Cannot specify link libraries for target “-L
    C:/esp/esp-adf-v2.3/components/esp-sr/lib” which is not built by this
    project.

    — Configuring incomplete, errors occurred!
    See also “C:/projects/CAB_ROLEC_ESP_PCB0325_G/build/VisualGDB/Debug/CMakeFiles/CMakeOutput.log”.
    See also “C:/projects/CAB_ROLEC_ESP_PCB0325_G/build/VisualGDB/Debug/CMakeFiles/CMakeError.log”.
    System.Exception: CMake exited with code 1
    at wn2.t(o b, Object a)

    ========== Project Configuration Summary ==========
    Cab configured in 00:04
    ========== Configuration: 1 Succeeded, 0 Failed, 0 Skipped ==========

     

    • This reply was modified 1 month ago by  orbitcoms.
    • This reply was modified 4 weeks, 1 day ago by  orbitcoms.
    #30800

    orbitcoms
    Participant

    I am wondering if I am using the right steps to create a new ADF project based on existing project.

    I cannot find anything in the tutorial related to setting up adf project based on existing project.

    The steps I took are below.

    “New VisualGDB Project”

    “ESP32/ESP8266 IDF/ADF Project Wizard” -> “ADD”

    “CMake(Recommended”

    “Import an existing project built with ESP-IDF, ESP-ADF…”

    Browse to project folder and select “CMakeLists.txt”

    “Next”

    Left this screen as default(same as was used for the play-mp3 demo project previously created)

    “Next”

    “Built-in GDB simulator(basic)

    “Finish”

     

    “Next”

     

     

     

     

    #30975

    Paul Wang
    Participant

    esp-adf is updated to support esp-idf v4.1,v4.3 since v2.0 last year. Now esp-adf-2.3 gives many new feature depending on idf-4.3,so it is neccessey to fix this bug。
    https://github.com/espressif/esp-adf/releases/tag/v2.0

    #30976

    orbitcoms
    Participant

    I have migrated all my projects except the ADF project from VSCODE to VisualGDB in Visual Studio.

    Really hoped I could get this running in Visual Studio but as much as I have tried, I cannot get it running.

    Are you saying there is a bug that needs fixing and this is why I cannot load my project? My ADF project works fine with both esp-idf 4.2 and the latest 4.3 and adf v2.3 in vscode but I don’t want to keep chaning development tools just for this one project.

     

    #30979

    Paul Wang
    Participant

    GCC 8.4 works fine for adf2.3 in vscode but not work in VisualGDB. I think there is a bug.

    #30980

    orbitcoms
    Participant

    That was my experience also, hope they can fix it at some stage.

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.