VisualGDB update to 5.4.110.3225-r10 fail: unexpected download size

Sysprogs forums Forums VisualGDB VisualGDB update to 5.4.110.3225-r10 fail: unexpected download size

Tagged: ,

This topic contains 5 replies, has 2 voices, and was last updated by  support 2 months, 4 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #25389

    regus_pregus
    Participant

    I am trying to update VisualGDB to version 5.4.110.3225-r10 in Visual Studio 2017 (15.9.14) using a built-in VisualGDB update facility (Tools->VisualGDB->Manage VisualGDB Packages->Updates.

    The update terminates with the following error message:

    VisualGDB version: 5.4.107.3207
    —————— System.Exception ——————
    System.Exception: Unexpected download size: 47820800, expected 47824896
    at i5.q1(String e, Int32 a, Int64 b, String c, String d)
    at i5.a2(URLWithParameters[] b, Int64 e, String c, Int32 d, mq1 a)
    at i5.l1.a(mq1 a)
    at VisualGDB.Common_GUI.WPF.ItemizedProgressWindow.<>c__DisplayClass2_2`1.<RunAction>b__0()

    #25390

    support
    Keymaster

    Hi,

    This looks like some cached data on your side is incorrect. Please try opening Tools->VisualGDB->Manage VisualGDB Packages->Online to update the package list.

    #25391

    regus_pregus
    Participant

    That didn’t help. By the way, while download is ongoing, the following exception occurs quietly (without error message):

    Downloading http://sysprogs.com/getfile/528/VisualGDB-5.4r10-trial.msi using 5 parallel threads…
    Multi-thread download exception: Mismatching hash after a multi-threaded download: 8b7a79e628e8be5a40e034aca587c460, expected 4fc2ce4b746fbc29bf30734ebf9e4fb1

    Then download restarts and then the error message I have mentioned in the original post comes up.

     

     

    #25392

    regus_pregus
    Participant

    For now I have worked around the problem by downloading the installer .msi file directly (outside of VS) and installing it.

    By the way, another problem: VisualGDB update window also shows Adafruit Circuit Playground update from 1.8.4 to 1.8.5, when I click on it, it reports that it is being installed, then reports that installaiton was successful, but then the same update keeps showing in the update list (and the version reported for this package still remains 1.8.4, so it looks like the update never actually installs). Any ideas?

    #25393

    regus_pregus
    Participant

    Update on Adafruit Circuit Playground playground issue: actually the list of installed packages now shows both versions 1.8.4 and 1.8.5 installed (instead of 1.8.5. replacing 1.8.4), and it shows that both of them are installed in the same folder.

    #25394

    support
    Keymaster

    Good to know the installer works now.

    Regarding the Arduino package numbers, indeed the default Arduino package layout would allow having multiple versions of the same package installed. This matches the behavior of the regular Arduino tools and should not cause any problems.  If you would like to reclaim the disk space used by the old packages, it is safe to simply delete their folders.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.