VisualGDB + IAR: startup_stm32h743xx.s not included

Sysprogs forums Forums VisualGDB VisualGDB + IAR: startup_stm32h743xx.s not included

This topic contains 4 replies, has 2 voices, and was last updated by  isigor 2 weeks, 1 day ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #28473

    isigor
    Participant

    Hi, I’m working with VisualGDB + IAR

    I have started to compare map output file produced via IAR only and VisualGDB+IAR

    For some reason vector_table if very different in size in both files, for example:

    VisualGDB+IAR output

    Section             Kind           Address          Size Object
    -------             ----           -------          ---- ------
    "A0":                                               0x40
    .intvec             ro code        0x800'0000       0x40 vector_table_M.o [7]
                                     - 0x800'0040 0x40

     

    IAR  output

    Section             Kind           Address          Size Object
    -------             ----           -------          ---- ------
    "A0":                                               0x298
    .intvec             ro code        0x800'0000       0x298 startup_stm32h743xx.o [1]
                                     - 0x800'0298       0x298

    I have noticed VisualGDB compilation ignores asm start up file, while IAR not,

    and that leads to using default vector_table_M

    How can I force VisualGDB to compile this startup_stm32h743xx.s file, without it, vector table if different and it leads to HardFaults

    Igor

     

    #28486

    support
    Keymaster

    Hi,

    Normally, VisualGDB should build the .s files as long as they are included in the project.

    If it doesn’t happen, please double-check that the file type is set to “C/C++ compiler” and it is not excluded from building:

    If you can confirm that the file type is consistently set incorrectly (e.g. when importing some project), please let us know the steps to reproduce it and we should be able to fix it.

    Attachments:
    You must be logged in to view attached files.
    #28497

    isigor
    Participant

    Hi, thanks for your response, but I found the problem for this 🙂

    (see attached image “Setting.png”)

    I don’t know if it’s bug or feature but if you choose assembly file to Compile as “Plain C” or “C++” it just exclude the file from compilation and will cause the behavior  I experienced before.

    My whole project uses C++ and therefore I set it to Compile as C++, which means all file set to this setting automatically , so I had manually remove “Compile as C++” in startup_stm32h743xx.s to make it compile again, and  it solved the problem.

    Best regards

    Igor

    Attachments:
    You must be logged in to view attached files.
    #28503

    support
    Keymaster

    Thanks for explaining this. We have updated VisualGDB to automatically reset the “Compile As” setting for assembly files in IAR projects. Please try this build: VisualGDB-5.5.7.3690.msi

    #28510

    isigor
    Participant

    Thanks, 5,5,7,3690 seems to do the job

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.