VisualGDB.exe /build ignoring /config

Sysprogs forums Forums VisualGDB VisualGDB.exe /build ignoring /config

This topic contains 4 replies, has 2 voices, and was last updated by  sorenml 5 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #25144

    sorenml
    Participant

    Hi,

    I am trying to automate my build process and everything is going great so far besides the fact, that I cannot get VisualGDB to build the project with command line with any other config than Debug.

    I am trying commands like: VisualGdb.exe /build /config:Deploy MyProject.vgdbproj

    It builds but I always get this in the output: “VisualGDB: Warning: No configuration specified, defaulting to ‘Debug’. Use ‘/config:<name>’ to override.”

    Any idea how to get this fixed?

    /Søren

    #25145

    support
    Keymaster

    Hi,

    This might be by design for some project types (e.g. Arduino or Mbed) that only support a fixed set of 2 configurations (Debug/Release).

    If you could attach a .vgdbproj file that triggers this, we should be able to tell more.

    #25147

    sorenml
    Participant

    Hi,

    I am running it directly from cmd and I have tried with /config:Release as well without luck. What i really need is only Debug and Release, so i can reduce logging in production. I have added the project file below, but removed the VirtualSourceFolder

     

    <?xml version=”1.0″?>
    <VisualGDBProjectSettings2 xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance” xmlns:xsd=”http://www.w3.org/2001/XMLSchema”>
    <ConfigurationName>Debug</ConfigurationName>
    <Project xsi:type=”com.visualgdb.project.external.esp-idf”>
    <CustomSourceDirectories>
    <Directories/>
    <PathStyle>Unknown</PathStyle>
    </CustomSourceDirectories>
    <ProjectModeSettings>
    <ProjectGUID>7674c0c4-703c-4b6f-86bb-0a7a422ba88b</ProjectGUID>
    <GroupSourcesByTypes>true</GroupSourcesByTypes>
    <GroupSourcesByPaths>true</GroupSourcesByPaths>
    <HeaderScanMode>SourceDirs</HeaderScanMode>
    </ProjectModeSettings>
    </Project>
    <Build xsi:type=”com.visualgdb.build.cmake”>
    <ToolchainID>
    <ID>com.visualgdb.xtensa-esp32-elf</ID>
    <Version>
    <GCC>5.2.0</GCC>
    <GDB>7.10</GDB>
    <Revision>16</Revision>
    </Version>
    </ToolchainID>
    <RelativeSourceDirectory/>
    <ConfigurationType>DEBUG</ConfigurationType>
    <BinaryDirectory>VisualGDB/$(ConfigurationName)</BinaryDirectory>
    <MakeCommandTemplate>
    <SkipWhenRunningCommandList>false</SkipWhenRunningCommandList>
    <RemoteHost>
    <HostName>BuildMachine</HostName>
    <Transport>BuiltinShortcut</Transport>
    </RemoteHost>
    <Command>$(VISUALGDB_DIR)/ninja.exe</Command>
    <Arguments/>
    <WorkingDirectory>$(BuildDir)</WorkingDirectory>
    <BackgroundMode xsi:nil=”true”/>
    </MakeCommandTemplate>
    <CMakeCommand>
    <SkipWhenRunningCommandList>false</SkipWhenRunningCommandList>
    <RemoteHost>
    <HostName>BuildMachine</HostName>
    <Transport>BuiltinShortcut</Transport>
    </RemoteHost>
    <Command>$(SYSPROGS_CMAKE_PATH)</Command>
    <BackgroundMode xsi:nil=”true”/>
    </CMakeCommand>
    <UpdateSourcesInCMakeFile>true</UpdateSourcesInCMakeFile>
    <ExportCompileCommands>false</ExportCompileCommands>
    <DisableToolchainFile>false</DisableToolchainFile>
    <ExtraConfigurationVariables>
    <string>-Werror=switch</string>
    </ExtraConfigurationVariables>
    <CMakeMakefileType>Ninja</CMakeMakefileType>
    <DeployAsRoot>false</DeployAsRoot>
    <ProjectModeSettings>
    <ProjectItemSettings>
    <GroupSourcesByTypes>true</GroupSourcesByTypes>
    <GroupSourcesByPaths>true</GroupSourcesByPaths>
    <GroupTargetsByPaths>true</GroupTargetsByPaths>
    <AutoRefreshProject>true</AutoRefreshProject>
    <SortTargetsByName>true</SortTargetsByName>
    <UseCMakeUpToDateCheck>false</UseCMakeUpToDateCheck>
    <RedundantTargetMode>HideOuterProjectTargets</RedundantTargetMode>
    <SortSourcesByName>true</SortSourcesByName>
    <BuildAllTargetsInSubdir>false</BuildAllTargetsInSubdir>
    <FoldSingleItemPathLevels>true</FoldSingleItemPathLevels>
    </ProjectItemSettings>
    <TargetSpecificSettings>
    <CMakeTargetSpecificSettings>
    <TargetID>main</TargetID>
    <Debug/>
    <Deployment>
    <Mode>Auto</Mode>
    <DeployIfNotSpecificallyReferenced>false</DeployIfNotSpecificallyReferenced>
    <DoNotDeployVersionedBinaries>false</DoNotDeployVersionedBinaries>
    </Deployment>

    <SetLDLibraryPathFromDependentArtifacts>true</SetLDLibraryPathFromDependentArtifacts>
    <ProjectGUID>72141596-a778-45ff-8365-c98e9be05c99</ProjectGUID>
    <VirtualFolders/>
    <ConfigurationNameCase>Upper</ConfigurationNameCase>
    <DefaultHeaderDiscoveryMode>HeaderDirectoryAndSubdirectories</DefaultHeaderDiscoveryMode>
    <ESPIDFExtension>
    <IDFCheckout>
    <Version>release/v3.2</Version>
    <Subdirectory>esp-idf/v3.2</Subdirectory>
    </IDFCheckout>
    </ESPIDFExtension>
    </ProjectModeSettings>
    </Build>
    <CustomBuild>
    <PreSyncActions/>
    <PreBuildActions/>
    <PostBuildActions/>
    <PreCleanActions/>
    <PostCleanActions/>
    </CustomBuild>
    <CustomDebug>
    <PreDebugActions/>
    <PostDebugActions/>
    <DebugStopActions/>
    <BreakMode>Default</BreakMode>
    </CustomDebug>
    <CustomShortcuts>
    <Shortcuts/>
    <ShowMessageAfterExecuting>true</ShowMessageAfterExecuting>
    </CustomShortcuts>
    <UserDefinedVariables/>
    <ImportedPropertySheets/>
    <CodeSense>
    <Enabled>True</Enabled>
    <CFLAGS>-Wno-switch</CFLAGS>
    <CXXFLAGS>-Wno-switch</CXXFLAGS>
    <ExtraSettings>
    <HideErrorsInSystemHeaders>true</HideErrorsInSystemHeaders>
    <SupportLightweightReferenceAnalysis>true</SupportLightweightReferenceAnalysis>
    <DiscoverySettings>
    <Mode>Silent</Mode>
    <SearchInProjectDir>true</SearchInProjectDir>
    <SearchInSourceDirs>true</SearchInSourceDirs>
    <SearchInIncludeSubdirs>true</SearchInIncludeSubdirs>
    <ExtraSearchDirs>
    <string>C:\SysGCC\esp32\opt\xtensa-esp32-elf\xtensa-esp32-elf\include\c++\5.2.0</string>
    <string>C:\SysGCC\esp32\opt\xtensa-esp32-elf\lib\gcc\xtensa-esp32-elf\5.2.0\include</string>
    </ExtraSearchDirs>
    </DiscoverySettings>
    <CheckForClangFormatFiles>true</CheckForClangFormatFiles>
    <FormattingEngine>ClangFormat</FormattingEngine>
    </ExtraSettings>
    <CodeAnalyzerSettings>
    <Enabled>false</Enabled>
    </CodeAnalyzerSettings>
    </CodeSense>
    <Configurations>
    <VisualGDBConfiguration>
    <Name>Debug</Name>
    <BuildSettingsExtension xsi:type=”com.visualgdb.build.external.esp-idf.extension”>
    <OutputSubdirectory>Debug</OutputSubdirectory>
    <SDKConfigFile>sdkconfig-debug</SDKConfigFile>
    <EnableVerboseBuild>false</EnableVerboseBuild>
    </BuildSettingsExtension>
    </VisualGDBConfiguration>
    <VisualGDBConfiguration>
    <Name>Release</Name>
    <BuildSettingsExtension xsi:type=”com.visualgdb.build.external.esp-idf.extension”>
    <OutputSubdirectory>Release</OutputSubdirectory>
    <SDKConfigFile>sdkconfig-release</SDKConfigFile>
    <EnableVerboseBuild>false</EnableVerboseBuild>
    </BuildSettingsExtension>
    </VisualGDBConfiguration>
    </Configurations>
    <ProgramArgumentsSuggestions/>
    <Debug xsi:type=”com.visualgdb.debug.embedded”>
    <AdditionalStartupCommands/>
    <AdditionalGDBSettings>
    <Features>
    <DisableAutoDetection>false</DisableAutoDetection>
    <UseFrameParameter>false</UseFrameParameter>
    <SimpleValuesFlagSupported>false</SimpleValuesFlagSupported>
    <ListLocalsSupported>false</ListLocalsSupported>
    <ByteLevelMemoryCommandsAvailable>false</ByteLevelMemoryCommandsAvailable>
    <ThreadInfoSupported>false</ThreadInfoSupported>
    <PendingBreakpointsSupported>false</PendingBreakpointsSupported>
    <SupportTargetCommand>false</SupportTargetCommand>
    <ReliableBreakpointNotifications>false</ReliableBreakpointNotifications>
    </Features>
    <EnableSmartStepping>false</EnableSmartStepping>
    <FilterSpuriousStoppedNotifications>false</FilterSpuriousStoppedNotifications>
    <ForceSingleThreadedMode>false</ForceSingleThreadedMode>
    <UseAppleExtensions>false</UseAppleExtensions>
    <CanAcceptCommandsWhileRunning>false</CanAcceptCommandsWhileRunning>
    <MakeLogFile>true</MakeLogFile>
    <IgnoreModuleEventsWhileStepping>true</IgnoreModuleEventsWhileStepping>
    <UseRelativePathsOnly>false</UseRelativePathsOnly>
    <ExitAction>None</ExitAction>
    <DisableDisassembly>false</DisableDisassembly>
    <ExamineMemoryWithXCommand>false</ExamineMemoryWithXCommand>
    <StepIntoNewInstanceEntry>app_main</StepIntoNewInstanceEntry>
    <ExamineRegistersInRawFormat>true</ExamineRegistersInRawFormat>
    <DisableSignals>false</DisableSignals>
    <EnableAsyncExecutionMode>false</EnableAsyncExecutionMode>
    <EnableNonStopMode>false</EnableNonStopMode>
    <MaxBreakpointLimit>0</MaxBreakpointLimit>
    </AdditionalGDBSettings>
    <DebugMethod>
    <ID>openocd</ID>
    <Configuration xsi:type=”com.visualgdb.edp.openocd.settings.esp32″>
    <CommandLine>-f interface/ftdi/um232h.cfg -f target/esp32.cfg -c “adapter_khz 3000″</CommandLine>
    <ExtraParameters>
    <Frequency xsi:nil=”true”/>
    <BoostedFrequency xsi:nil=”true”/>
    <ConnectUnderReset>false</ConnectUnderReset>
    </ExtraParameters>
    <LoadProgressGUIThreshold>131072</LoadProgressGUIThreshold>
    <ProgramMode>Enabled</ProgramMode>
    <StartupCommands>
    <string>set remotetimeout 60</string>
    <string>target remote :$$SYS:GDB_PORT$$</string>
    <string>mon gdb_breakpoint_override hard</string>
    <string>mon reset halt</string>
    <string>load</string>
    </StartupCommands>
    <ProgramFLASHUsingExternalTool>false</ProgramFLASHUsingExternalTool>
    <PreferredGDBPort>0</PreferredGDBPort>
    <PreferredTelnetPort>0</PreferredTelnetPort>
    <SuggestionLogicRevision>0</SuggestionLogicRevision>
    <CheckFLASHSize>true</CheckFLASHSize>
    <FLASHSettings>
    <Size>size2MB</Size>
    <Frequency>freq40M</Frequency>
    <Mode>DIO</Mode>
    </FLASHSettings>
    <PatchBootloader>true</PatchBootloader>
    </Configuration>
    </DebugMethod>
    <AutoDetectRTOS>true</AutoDetectRTOS>
    <SemihostingSupport>Auto</SemihostingSupport>
    <SemihostingPollingDelay>0</SemihostingPollingDelay>
    <StepIntoEntryPoint>false</StepIntoEntryPoint>
    <ReloadFirmwareOnReset>false</ReloadFirmwareOnReset>
    <ValidateEndOfStackAddress>true</ValidateEndOfStackAddress>
    <StopAtEntryPoint>false</StopAtEntryPoint>
    <EnableVirtualHalts>false</EnableVirtualHalts>
    <DynamicAnalysisSettings/>
    <EndOfStackSymbol>_estack</EndOfStackSymbol>
    <TimestampProviderTicksPerSecond>0</TimestampProviderTicksPerSecond>
    <KeepConsoleAfterExit>false</KeepConsoleAfterExit>
    <CheckInterfaceDrivers>true</CheckInterfaceDrivers>
    </Debug>
    </VisualGDBProjectSettings2>

    #25163

    support
    Keymaster

    Unfortunately, the project file you copied is corrupt (e.g. the CMakeTargetSpecificSettings tag is not closed), so we were not able to reproduce the issue with it.

    We have tried creating a similar project from scratch (ESP-IDF, CMake) and built it using the following command line:

    This did work as expected. Please double-check that you are using the latest VisualGDB version and that the newly created project builds the release configuration as expected.

    Then try comparing your project with the newly created one to see what setting could be interfering with the configuration selection from command line.

    #25168

    sorenml
    Participant

    Upgrading to newest version made all the difference, thank you 🙂

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.