VisualGDB disappeared from the Visual Studio UI after update

Sysprogs forums Forums VisualGDB VisualGDB disappeared from the Visual Studio UI after update

This topic contains 4 replies, has 3 voices, and was last updated by  parsec67 3 weeks, 6 days ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #31742

    codefrog
    Participant

    I did two things today – updated Visual Studio 2019 to 16.11.6, and installed Visual Studio 2022.

    After that, Visual GDB (5.5?) was still working to make builds but the “VisualGDB Properties” disappeared from the usual place I find it : right clicking the project in the Solution Explorer, expect to see VisualGDB Properties as the first item.  Additionally File > New > didn’t offer VisualGDB project.

    Disabling and Re-enabling VisualGDB extension didn’t have any effect.

    Attempting to run VisualGDB-5.6-trial.msi said “Unknown Major VS Version 17” and then later in the process stopped with “The specified account already exists” and reverted all its work. (Ended prematurely, your system has not been modified)

    Attempting to uninstall VisualGDB gave an error with a missing license.rtf in a deep path; by placing a blank license.rtf in that location I was able to successfully complete the uninstall process.

    But now all attempts to reinstall VisualGDB 5.6 or 5.5 are giving me “The specified account already exists”.

    Please help…

     

     

    #31739

    parsec67
    Participant

    Hi,

    Just installed VS2022 Community yesterday and today I tried installing VisualGDB 5.6 using the downloaded file VisualGDB-5.6-trial.msi. It did not go well.

    In the setup wizard I select “Change”, then untick Visual Studio 2019 since I already have VGDB installed for this version. The setup begins, prompts if  I want to allow it to make changes etc. but then almost instantly quits with the message “ended prematurely”. Please see attached screenshots.

     

    Attachments:
    You must be logged in to view attached files.
    #31743

    codefrog
    Participant
    #31748

    support
    Keymaster

    Hi All,

    Indeed, uninstalling Visual Studio while VisualGDB is already installed may trigger a few issues in the installer logic. Following our troubleshooting instructions usually helps resolve them very fast.

    #31767

    parsec67
    Participant

    Happy to report that this solution worked for me too, although I didn’t see any of the error messages that codefrog mentioned. In my case it was a previously uninstalled VS2017 environment that caused the VGDB setup wizard to error out.

    Thanks!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.