visualddk issues

This topic contains 1 reply, has 1 voice, and was last updated by  Anonymous 6 years, 8 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #369

    Anonymous
    Participant

    Hi,

    First of all this project sounds very interesting, thank you for your hard work!!

    first I tried my luck with virtualbox 4.2 (I tried to compile the modules, as far as it goes for the c++ modules it seems like it was okay, I had to convert several configurations to visual studio 10). Although finally I gave up on it because vmmon did not work correctly neither with the latest virtualbox header.

    So then I tried to switch back to virtualbox 4.1, at a first glance it seemed to work, however it quickly end up nowhere.
    Now if I start vmmon I get the message
    VirtualKD cannot patch Virtualbox on the fly.
    Please register the virtualkd device for virtualbox by running regsvr32 vboxkd64.dll if this does not help, close all instances of virtualbox and terminate …

    Can you please update the sources with the latest version? Because there seems to be a mismatch between the binaries which you offer and the sources which are downloadable

    UPDATE WHILE WRITING THAT, I did above thing a 3rd time 2 times it failed.
    I left the virtual machine monitor running in the background and only restarted virtualbox (restarting the vmmon would probably lead to the same problem which I had just before).

    OK so let’s go on here, in Visual Studio 10 I’m starting th eVisualDDK Driver Project Launcher and set up windows 7 through the 3rd “debugging connection setup” option and click Save, everything okay until here

    secondly I open that one again and click launch and I get an error (sorry it vanished too quick I’ll try to catch it next time)

    I open the Driver Project launcher again and it seems to go on now – wait stop nothing happens.
    Ok I close the virtual machine monitor and it really goes on, on the VisualDDK Console I can see many Unable to deliver callback, 31 messages does anyone know what that means?

    Ok going on from here I start up windows and start the launch monitor the launch monitor prints “discovery request from 192.168.2.226”
    while doing that the “driver launch in progress” window only prints
    Contacting VisualDDK Launch monitor on via UDP…
    Detecting remote machine IP address…

    I’m stuck here… I’ll keep updating this when it goes on. If someone has some more experience with it please help 🙂

    #1994

    Anonymous
    Participant

    Finally I got it work too.

    I started up vmmon and I’m using the named pipe to connect to the win7 vm.

    Driver loading and unloading works! (no lockup of visual studio like another user reported in the forum).

    When it tries to discover the remote host I picked the IP address of the virtual machine and entered it manually (it did not seem like an input field because it flashes quickly and deletes all the input, so typing in the IP address is impossible but someone can copy and paste the ip address and press return quickly

    bazis it would be really nice if you could update this genius application and/or the sourcecode for it

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.