VirtualKD + Windows 10

Sysprogs forums Forums VisualDDK/VirtualKD discussion VirtualKD + Windows 10

This topic contains 12 replies, has 7 voices, and was last updated by  makki 1 month, 3 weeks ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #6572

    Sloubi
    Participant

    Hello,

    First of all, thank you for VirtualKD, it’s a blessing for my job.
    I would like to know if there will be a version of VirtualKD available for Windows 10. In the last developper preview (build 10130) VKD’s setup works fine but when rebooting, kdbazis.dll seems to not be loaded (even when the signature enforcement is disabled). Windows 10 is not breaking at startup and VMMon doesn’t “establish” the connection with the OS (No ‘Yes’ in the ‘OS’ column).

    Thank you in advance

    Best regards

    #6720

    mike_srv
    Participant

    on RTM 10240 build same problem – transport didn’t load. Can you fix this issue ?

    #6728

    makki
    Participant

    1. VM: Copy kdbazis.dll and kdpatch.sys to C:\Windows\System32\drivers\
    from virtualKD\target\x86 or x64.
    2. VM: Run kdpatch.reg.
    3. VM: Enable debug by serial port. (Use bcdedit or msconfig. Not vminstall.exe.)
    4. Host: Start kernel debug by Windbg with serial port, and run vmmon.exe/vmmon64.exe.
    After 5~10 seconds, Virtual Machine monitor starts transportation and debugging.

    #6729

    mike_srv
    Participant

    thanks, it works.

    ps: win10 must be booted with “disable signature enforcement” option, like win8/win8.1

    #7019

    support
    Keymaster

    Hi All,

    Please try version 3.0. It supports Windows 10 with the normal vminstall tool.

    #8164

    Sloubi
    Participant

    Hello again!

    In order to avoid creating too much topics about Windows 10, I’ll just use this one. I’m trying the latest Insider build (14295.1005) of Windows 10 and I have the same trouble as with the version 2.8 + Windows 10 back then. I’ve followed what makki wrote and it worked fine on my Insider build.
    FYI, the boot entry didn’t have the COM port configured and the DLLs weren’t copied in the drivers directory.

    Just to let you know that it doesn’t work “out of the box” but there is a workaround.

    Thanks!

     

    #8314

    Sloubi
    Participant

    Hi!

    Just to let you know, VKD doesn’t work with the new Insider 14342 (both x86 and x64), even when trying to setup everything manually, following makki’s comment above. I’ll keep you in touch in case I found a solution.

    PS: Sorry for the spam, I guess this kind of information may help the devs of VKD, maybe, dunno.

    • This reply was modified 2 years, 4 months ago by  Sloubi.
    #8316

    Sloubi
    Participant

    Well, found my solution! It lacked the patched kdcom.dll in the system32 directory (and also the backup of the old one). So if you have any trouble with the Insiders build, just follow makki’s comment and add the kdcom.dll too. Should work fine!

    #8875

    pilon
    Participant

    Sloubi, I have same problem with official Windows 10 Anniversary update (14393).

    I try to follow makki solution, VKD don’t start. How to patch kdcom.dll manually or where find already patched kdcom.dll for this Windows buid?

    Please, write detail instruction.

    #9361

    khan
    Participant

    Same problem for here in the same version

    #9444

    Sloubi
    Participant

    Pilon, Khan,

    Nice Solution (not tested though): As far as I recall, this is due to very restricted ACL on the kdcom.dll. Maybe soften them up a bit should do the trick and VKD would patch it fine all by itself.

    Dirty Solution (but works for me): When kdcom.dll wasn’t set up (you can detect this situation by checking if there is a kdcom_old.dll in the system32 folder), then you can copy the patched kdcom.dll from a 1511 after you’ve installed VKD on it.

    On my 14931, the DLL was correctly patched, but the drivers weren’t copied and the boot entry was still setup as Firewire. Copying manually the drivers and setting up the correct debug mode for the VKD entry did the trick.

    Sorry for the late answer, I don’t come here very often

    #21705

    ricnar456
    Participant

    i solved the problem for installation in windows 10 post anniversary update.

    The problem is in kdcom.dll, the owner is TrustedInstaller not admin, and admin has no privileges to replace delete or change that file, manually or using VKD.

    You need open the properties of that file and change the owner to admin

    Windows 7/8/10 – How to Delete Files Protected by TrustedInstaller

    that link is for windows 7 is very similar, not exactly but is the idea, changing the owner to admin, and giving to admin full control to modify, delete, change the dll, yo can run the VKD installer and works replacing kdcom.dll.

    next from a admin console

     

    #21839

    makki
    Participant

    I found the solution without security setting in windows 10 post anniversary update.

    1. Run vminstall.exe to install.

    2. Run msconfig -> Boot tab.
    Select “Disable Signature Enforcement…[Virtual KD]..” and Click “Advanced options”.
    Change Debug port “COM1” from “1394”.

    3. Restart and press f8 for disable driver signature.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.