VirtualKD VMInstall bug

Sysprogs forums Forums Other tools & products VirtualKD VMInstall bug

This topic contains 3 replies, has 3 voices, and was last updated by  stifenhowk 12 years, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #111

    Anonymous
    Participant

    Hi there,

    I have never been able to successfully install VirtualKD on the target using the installer targetvminstall.exe, I always seemed to get “Error – cannot access boot configuration data”.

    Tired of this failing on multiple versions, I decided to build and debug it myself rather than submitting a query. I have solved the problem, here I detail the bug(?) and solution:

    In bootedit.cpp on line 546 is the following test:

    if (!m_OSEntries.empty() && !m_Default.GetValue().empty() && !m_Timeout.GetValue().empty())
    m_bValid = true;

    This test was failing, leaving m_bValid false, causing the error. I narrowed it down to the return from m_Default.GetValue().empty(), and discovered this was erroneously returning that m_Default was empty.

    In my boot.ini I noticed that the ‘default’ line begins with a forward slash (/default), I assume this is the case for everyone. I then noticed that line 536 had the test:

    else if (!key.icompare(“default”))

    and line 534 has:

    if (!key.icompare(“timeout”))

    Now the timeout line has no forward-slash, so without wanting to waste further time debugging the key.icompare function, I decided to try changing line 536 to:

    else if (!key.icompare(“/default”))

    This worked and fixed the installer for me, so I assume this function was failing because of the forward slash. I can’t fathom how it could have worked for other people (XP SP2 guest) but I can’t afford to spend any more time on this.

    I hope this might be helpful for others.

    Kind regards,

    Kev

    #1175

    Anonymous
    Participant

    I’ve just noticed that on other machines, the forward slash is missing. Not sure what’s going on here, but it seems to be present in only *some* systems… or only my system?!

    Bit of a mystery, I assume therefore that I’m in the minority with the forward slash before ‘default’ but if any body else has this problem I guess you can just remove the forward slash!

    Sorry for wasting your time if my forward slash was unique 😳

    kev

    #1176

    support
    Keymaster

    The forward slash seems to be your unique case (some third-party boot manager?). Anyway, I’ll add support for both “default” and “/default” in the future versions. Thanks for investigating the problem 😉

    #1177

    stifenhowk
    Participant

    Hello kevoreilly.
    I read your entire problem if you are change your hardware then it will be install and first check your all drives with good anti-virus.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.