Using the Profiler on Raspberry Pi4

Sysprogs forums Forums VisualGDB Using the Profiler on Raspberry Pi4

This topic contains 3 replies, has 2 voices, and was last updated by  support 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #31911

    Brian Beuken
    Participant

    Hi

    Im having a bit of an issue, I’ve been trying to use the Visual GDB profiler, on a Raspberry Pi4 project.   As a compiler/debugger I get no issues and I’ve been happily using VisualGDB  for quite a few years now.. But I wanted to see how the profiler worked on the Pi4 to try to identify some bottlenecks and check for memory leaks. But I’m not getting anywhere with it, my 1st attempts to use it, it insisted on installing valgrind, which I didn’t mind, but from then on using it is a no go, every option throws up a console output of numerous issues that I can’t resolve.. This is just the tail end of it. It always ends up crashing on an illegal instruction before the project even gets into run

    ==14245== valgrind: Unrecognised instruction at address 0x78b59e0.
    ==14245== at 0x78B59E0: llvm::cl::OptionCategory::registerCategory() (in /usr/lib/arm-linux-gnueabihf/libLLVM-11.so.1)
    ==14245== Your program just tried to execute an instruction that Valgrind
    ==14245== did not recognise. There are two possible reasons for this.
    ==14245== 1. Your program has a bug and erroneously jumped to a non-code
    ==14245== location. If you are running Memcheck and you just saw a
    ==14245== warning about a bad jump, it’s probably your program’s fault.
    ==14245== 2. The instruction is legitimate but Valgrind doesn’t handle it,
    ==14245== i.e. it’s Valgrind’s fault. If you think this is the case or
    ==14245== you are not sure, please let us know and we’ll try to fix it.
    ==14245== Either way, Valgrind will now raise a SIGILL signal which will
    ==14245== probably kill your program.

     

    Has anyone had the profiler working on a Pi4? Is there some tutorial I can view to get some valid output from it? I’m using Raspberry Pi4, with 32bit Bullseye when this crashes

    I get a slightly different resutl on Pi4 on 32bit Buster, it does not crash, but it also dosn’t seem to produce any output or allow the project to progress, effectively I’m sat looking at a PC screen doing nothing.

     

    Are there any tutorials on using the profiler?

     

    thanks

     

    Brian

     

    #31915

    support
    Keymaster

    Hi,

    It looks like valgrind may not be 100% compatible with your version of Raspberry Pi OS yet. You can try installing an older version of the OS/toolchain thta might work better (see this page) or submitting this issue to valgrid developers, so that they could consider fixing it.

    #31917

    Brian Beuken
    Participant

    hmm Im rather commited to using Bullseye now as it has some features I need to use.. What version of the Raspberry OS do you know works?

     

     

    #31925

    support
    Keymaster

    Hi,

    This is something to check on the Raspberry Pi forum. As far as VisualGDB is concerned, if valgrind itself works as expected, VisualGDB will work with it as well.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.