Using J-Link for RP2040

Sysprogs forums Forums VisualGDB Using J-Link for RP2040

This topic contains 1 reply, has 2 voices, and was last updated by  support 1 month, 3 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #33774


    I’m trying to use a Segger J-Link Mini EDU to load and debug a FreeRTOS-SMP project on Raspberry Pi pico.

    On the properties page, I entered…

    Debug using: Segger J-Link

    Debug method: J-Link Software

    Debugged device: RP2040_M0_0

    Debug interface: SWD

    Clock speed(Khz): 3000

    When I click the [Test] button it says…  Connect test succeeded.

    I set a breakpoint a few lines past main(), then one just before starting the scheduler, so at this point, I’m only running on core 0.

    When I try “step into new instance”, my PC says “USB device not recognized”.  The last thing in VisualGDB Output is “Starting target CPU…”, but nothing is happening. The J-Link Web Control panel shows that the J-Link is connected and lists the breakpoints.

    If I click on pause, I can see that the program is in a loop…

    0x00000030 30 BF wfi
    0x00000032 FD E7 b.n 0x30

    I have no idea how it got here, but it happens every time – even after a complete reboot.

    Are there any other settings that I need to check?







    This is actually handled by the J-Link GDB stub. VisualGDB launches it when you press F5, and relies on it to handle the low-level debug interaction.

    We would advise checking this with Segger support whether the SMP mode is supported for RP2040; if there is a special command or a command-line parameter that enables it, feel free to post it here and we will help you configure VisualGDB to use it.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.