UnitTest with build on Host via CrossTool

Sysprogs forums Forums VisualGDB UnitTest with build on Host via CrossTool

This topic contains 2 replies, has 2 voices, and was last updated by  ThomasM 6 months, 3 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #11244

    ThomasM
    Participant

    Hi there,

    I’m currently developing for a Intel Edison and would like to get a unit test running.┬áBecause the project will expand more and more it would be nice to use the cross-compile method.

    In the tutorial (https://visualgdb.com/tutorials/tests/googletest/) a MSBuild for the unit test is used. It says that it’s also able to build with a cross toolchain tool. So I choosed the “Build the project locally with a cross-compiler” and got an error message after clicking finish:

    When I try to build the project the <ctype> and <string> headers are missing and the compilation process fails. How can I fix the problem? It seems that the GoogleTest Framework is stored in C:\Users\Thomas\AppData\Local\VisualGDB\TestFrameworks\com.sysprogs.unittest.googletest\. My files and the Cross-Toolchain are in a different path.

    Is there anything special compared to the build toolchain described in https://visualgdb.com/tutorials/linux/edison/ ? Maybe a special unit test tutorial for the Intel Edison ­čśë ?

    Greetings,
    Thomas

     

    **** EDIT ****

    Forgot to say: I need the cross-compile toolchain for the compile process. The edison itself takes to much time for the compile process…

     

    • This topic was modified 6 months, 4 weeks ago by  ThomasM.
    #11247

    support
    Keymaster

    Hi,

    The Edison toolchain might require an explicit “–sysroot” argument. Please try specifying it via additional command line flags for both compiler and linker (see the toolchain documentation or included examples for the correct sysroot value).

    #11248

    ThomasM
    Participant

    That’s right. The tutorial suggested me to use the MSBuild instead of the GNU build. I choosed the GNU and set the sysroot settings as usual. Worked.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.