Undefined MI command

Sysprogs forums Forums VisualGDB Undefined MI command

This topic contains 5 replies, has 2 voices, and was last updated by  support 3 weeks, 3 days ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #26484

    walli7
    Participant

    I’m trying to debug a executable on a UNIX machine with Visual Studio, but I get always this error, why?

    Undefined MI command: list-features
    Undefined MI command: inferior-tty-set
    mi_cmd_break_insert: Unknown option f”
    Undefined mi command: file-list-exec-source-files (missing implementation)
    Undefined mi command: file-list-exec-source-files (missing implementation)

    #26485

    support
    Keymaster

    Hi,

    Looks like your gdb version does not support some of the gdb/mi commands used by VisualGDB. Normally, updating to gdb 7.0 or later (although we recommend the latest 8.3.1 release) should solve the problem.

    #26486

    walli7
    Participant

    I’m using GNU gdb 6.1.1

    But it still does not work.

    (gdb begin)
    — GDB Session —
    VisualGDB is licensed to [censored]
    ~”GNU gdb 6.1.1 [FreeBSD]\n”
    ~”Copyright 2004 Free Software Foundation, Inc.\n”
    ~”GDB is free software, covered by the GNU General Public License, and you are\n”
    ~”welcome to change it and/or distribute copies of it under certain conditions.\n”
    ~”Type \”show copying\” to see the conditions.\n”
    ~”There is absolutely no warranty for GDB. Type \”show warranty\” for details.\n”
    ~”This GDB was configured as \”i386-marcel-freebsd\”…”
    -gdb-version
    ~”\n”
    ~”GNU gdb 6.1.1 [FreeBSD]\n”
    ~”Copyright 2004 Free Software Foundation, Inc.\n”
    ~”GDB is free software, covered by the GNU General Public License, and you are\n”
    ~”welcome to change it and/or distribute copies of it under certain conditions.\n”
    ~”Type \”show copying\” to see the conditions.\n”
    ~”There is absolutely no warranty for GDB. Type \”show warranty\” for details.\n”
    ~”This GDB was configured as \”i386-marcel-freebsd\”.\n”
    ^done
    Warning: you are using an old GDB (s01) that has known issues. Please update to a newer version.
    -list-features
    ^error,msg=”Undefined MI command: list-features”
    -gdb-set verbose on
    ^done
    -gdb-set disassembly-flavor intel
    001^done
    ^done
    -gdb-set print demangle off
    ^done
    -break-insert -f main
    &”mi_cmd_break_insert: Unknown option f”\n”
    ^error,msg=”mi_cmd_break_insert: Unknown option f””
    -break-insert main
    -gdb-set index-cache directory /VisualGDB/app/Debug/GDBSymbolCache
    &”No symbol \”index\” in current context.\n”
    ^error,msg=”No symbol \”index\” in current context.”
    -gdb-set index-cache on
    &”No symbol \”index\” in current context.\n”
    ^error,msg=”No symbol \”index\” in current context.”
    -inferior-tty-set /dev/pts/3
    ^error,msg=”Undefined MI command: inferior-tty-set”
    t 0x83fef6b <_ZN10CLoginData6SetKeyEj+11>.\n”
    ^done
    -file-list-exec-source-files
    ^error,msg=”Undefined mi command: file-list-exec-source-files (missing implementation)”
    -data-evaluate-expression “sizeof(void *)”
    ^done,value=”4″
    -target-attach 58121
    ^error,msg=”Undefined mi command: target-attach (missing implementation)”

    • This reply was modified 3 weeks, 3 days ago by  walli7.
    #26488

    support
    Keymaster

    Sorry, VisualGDB does not support GDB 6.1, as it is more than 15 years old and is missing many critical functionality. If you absolutely have to use this version, we could add limited support for it as a custom paid feature. Please contact our sales to get a quote.

    #26489

    walli7
    Participant

    I have now installed a never version of GDB which is supported. Now the mi issue does not exist anymore.

    But I get the error “Failed to start DGB Session.” “^error,msg=”Couldn’t get registers: Device busy.”

    • This reply was modified 3 weeks, 3 days ago by  walli7.
    #26491

    support
    Keymaster

    Looks like you are referring to the this thread.

    We have mentioned that the oldest version of FreeBSD tested with SysprogsSync was 9.3. Once you provided more details, we pointed out that the error was caused by a 32-bit build of FreeBSD, and that using a 64-bit build, or patching SysprogsSync as we suggested, would solve the problem.

    If you do not have any specific version constraints, please try using a 64-bit build of the latest FreeBSD. Although some minor functionality may not work as expected, most of the functionality should work.

    It also looks like your forum account is using a different email address that is not linked to your license key. Please let us know the email address associated with your key via the support form, or update the forum profile accordingly, so that we could link it to your support profile.

    Edit: the latest error looks like the latest gdb might not be compatible with the FreeBSD version you are using. Sorry, unfortunately this is outside of VisualGDB’s control. Please try installing the latest 64-bit FreeBSD as suggested above.

     

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.