Time stamp issues?

Sysprogs forums Forums VisualGDB Time stamp issues?

This topic contains 11 replies, has 3 voices, and was last updated by  viordash 3 days, 13 hours ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #23586

    Brian Beuken
    Participant

    I’m getting a lot of strange errors, suddenly on all projects, but I’ve not altered the time on my PC or my targets which all show the correct current time.

    The numbers and files/folders seem to vary and it doesn’t seem to stop the files being sent to the target but its a bit odd and I cant find a cause for it.

    1>EXEC : warning : Stderr line received ‘tar: Assets: time stamp 2019-01-26 15:28:15 is 3587.90668868 s in the future’

     

    any ideas?

     

     

    #23589

    support
    Keymaster

    Hi,

    Most likely your targets have a different time zone from the development machine. Please consider adjusting them, or simply add the timestamp offset via Tools->VisualGDB->Manage SSH Connections->Per-host Settings. You can also disable the tar timestamps completely in the same window if you want to restore the v5.3 behavior (setting timestamps to the time of transfer, not the original time of the files on Windows).

    #23595

    Brian Beuken
    Participant

    That was my 1st thought, since the 3587 seconds is basically 1 hour out, and I am in the Netherlands using +1 from UTC, but both my main system and Raspberry target, take their time signals from the internet and are both set to UTC+1. So both are in the same time zone…its kinda strange.

     

    I don’t seem to have Tools->VisualGDB->Manage SSH Connections->Per-host Settings as an option but I do have SSH Host manager, however it gives me no offsets or timestamp options

    I am using VisualGDB 5.4 beta 2, 2675

     

    • This reply was modified 1 year, 3 months ago by  Brian Beuken.
    #23597

    Brian Beuken
    Participant

    Reverting back to SCP transfer on the specific SSH connection for a device seems to have resolved it… maybe there’s an issue in your time checks?

    #23598

    support
    Keymaster

    Hi,

    Sorry, the page inside SSH Connection Manager is called “host-wide settings” and you will need to create an entry for your host in order to configure the timestamp difference.

    #28129

    viordash
    Participant

    Hi.

    I have same issue. “Stderr line received ‘tar: Utils: time stamp 2020-05-14 14:50:13 is 10798.260748773 s in the future'”

    VisualGDB 5.5.5.3573.

    Timestamp offset settings is not helped in my case. I don’t see any impact when changing the value.

    Changing time in the build machine (Linux Mint) is helped, the warning messages are no longer displayed

    #28138

    support
    Keymaster

    No problem, please try this build: VisualGDB-5.5.5.3618.msi

    It will display the currently used timestamp offset in the build log after the warning suggesting to use the Host-wide settings, e.g.:

    Please try the following steps to narrow down the problem:

    1. Build the project normally. Locate the current timestamp message and the “time stamp in the future” warning in the build log.
    2. Try adjusting the value in Host-wide settings (e.g. subtract 1000 from it).
    3. Build the project again and locate the updated messages.

    Please share the messages from both builds and we should be able to track this down.

    #28165

    viordash
    Participant

    So far, your decision has not helped. I noticed that the “Timestamp offset” setting only affects to files. But it has no effect on folders.
    BTW, the time of folders on the build machine is constantly changing during compilation. But the modified time of the files, only if changed their contents.
    Here are 2 messages, with different settings (10800 and -10800)
    —-
    Stderr line received ‘tar: Utils: time stamp 2020-05-20 18:58:57 is 10800.210223503 s in the future’
    The target’s clock might be out-of-sync with this computer’s clock. Use the Tools->VisualGDB->SSH Host Manager->Host-wide Settings to configure the timestamp offset.
    Current timestamp offset for viordash-virtual-machine is 10800 (generation=14).
    make CONFIG=Debug
    —-
    Stderr line received ‘tar: Utils: time stamp 2020-05-20 19:00:06 is 10800.298549338 s in the future’
    The target’s clock might be out-of-sync with this computer’s clock. Use the Tools->VisualGDB->SSH Host Manager->Host-wide Settings to configure the timestamp offset.
    Current timestamp offset for viordash-virtual-machine is -10800 (generation=15).
    make CONFIG=Debug

    Utils is a folder, and its modification time on the build machine is Wed 20 May 2020 07:00:06 PM MSK

    #28175

    support
    Keymaster

    Thanks for clarifying everything. We have pinpointed and fixed the problem in the following build: VisualGDB-5.5.5.3626.msi

    #28176

    viordash
    Participant

    Thank you, warnings messages are fixed.

    A minor comment, I noticed that the modification time for files and folders differs with time zone value (my tz is +3)

    In attachment I put the screenshot “2020-05-21_22-05-03.png”

    Attachments:
    You must be logged in to view attached files.
    #28181

    support
    Keymaster

    No problem, we have updated VisualGDB to use UTC times for folders, similar to files: VisualGDB-5.5.5.3628.msi

    #28183

    viordash
    Participant

    Thank you, now everything is correct

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.