TFS Team Foundation Server Problem with Visual GDB

Sysprogs forums Forums VisualGDB TFS Team Foundation Server Problem with Visual GDB

Tagged: ,

This topic contains 8 replies, has 2 voices, and was last updated by  support 4 months, 2 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #25170

    Yonk
    Participant

    Hi every one

    Im new to the game and need a little help 🙂

    some how I have trouble with TFS it always brings an error when i open my Solution.

    Error: The project file C:\…\EIP_Firmware.vgdbproj is not bound to source control, but the solution contains source control binding information for it.
    Do you want to open the project using source control binding information from the solution or open it as unbound and fix the solution file?

    I can choose:
    –  Use solution binding (Result: I can Check-In and Out but have to do it by hand not automatic like it should be and there are no locks or other icons, just one on the solution)

    –  Remove solution binding (Binding removed)

     

    I tried to

    • create new project
    • Re added bindings
    • Re created EIP_Firmware.vgdbproj

    Thanks for your help

    • This topic was modified 5 months ago by  Yonk.
    Attachments:
    You must be logged in to view attached files.
    #25178

    support
    Keymaster

    No problem. We have rechecked the TFS integration with the latest VS build and it looks like the Arduino projects were indeed not handling it correctly.

    Please try this build: VisualGDB-5.4.107.3206.msi

    If the message still appears, please select the “Use solution binding” option. The SCC icons should now work.

    In order to eliminate the message completely, please enable View->Other Windows->VisualGDB Diagnostics Console (using the new build), create a new project in a source-controlled directory and let us know:

    1. Whether the lock icons appear after you created the project
    2. If yes, whether they reappear after you reopen the solution
    3. The full log from the Diagnostics Console showing the messages from creating and reopening the solution
    #25200

    Yonk
    Participant

    Thank you

    1. The Icons appear
    2. works also but still the Source Control Message appears:

    The project file C:\SMTProject\SSS\ArduinoProjectTestGDB1\ArduinoProjectTestGDB1\ArduinoProjectTestGDB1.vgdbproj is not bound to source control, but the solution contains source control binding information for it.
    Do you want to open the project using source control binding information from the solution or open it as unbound and fix the solution file?

    if I click on Use solution binding then it work till I reload the solution

    Attachments:
    You must be logged in to view attached files.
    #25202

    support
    Keymaster

    Thanks for the log file, it looks like our bug. We have fixed the problem in the following build: VisualGDB-5.4.108.3212.msi

    #25203

    Yonk
    Participant

    Thank you, now it  works smoothly!!

    #25209

    Yonk
    Participant

    Some times the error pups up. I checked the file is there and it’s not read only.

     

    EIP_Firmware.ino has been automatically checked out for editing.
    The item C:\SMTProject\SSS\SMT-91-0104_EIP_Firmware\SMT-91-0104_EIP_Firmware\SMT-91-0104_EIP_Firmware.vgdbproj.vspscc could not be found in your workspace, or you do not have permission to access it.
    SMT-91-0104_EIP_Firmware.vgdbproj has been automatically checked out for editing.

    #25215

    support
    Keymaster

    It looks like VSS might expect some extra notifications from the Arduino projects. Please try narrowing it down to a specific sequence of actions that reliably triggers the problem and we will investigate it and try adding a workaround.

    #25235

    Yonk
    Participant

    The whole Solution is checked-in and I edit any .ino or .h files just the .ino or .h file is checked out not the Project. Don’t know if it’s really a failure.

    #25245

    support
    Keymaster

    Normally, unless you change a specific project-level setting (e.g. add another sketch file), the project itself doesn’t need to be checked out, so based on what you have described, this looks OK.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.