template {{ENTER}} question

Sysprogs forums Forums VisualGDB template {{ENTER}} question

This topic contains 2 replies, has 3 voices, and was last updated by  michael127001 14 hours, 50 minutes ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #32778

    kenohuyi
    Participant

    Hello,

    Every time I type template {{ENTER}} the next line is indented.

    This is very irritating. How can it be disabled?

    #32779

    support
    Keymaster

    Unfortunately, it is hard to suggest anything specific based on the description you provided.
    In order for us to provide any help with this, we need to be able to reproduce the problem on our side.
    Please provide complete and detailed steps to reproduce the issue as described below:

    1. The steps should begin with launching Visual Studio. They should include every step necessary to create the project from scratch and reproduce the issue.
    2. Please make sure the steps do not involve any 3rd-party code as we will not be able to review it. If the problem only happens with a specific project, please make sure you can reproduce it on a clean project created from scratch.
    3. The steps should include uncropped screenshots of all wizard pages, VisualGDB Project Properties pages and any other GUI involved in reproducing the problem. This is critical for us to be able to reproduce the problem on our side.

    You can read more about the best way to report VisualGDB issues in our problem reporting guidelines, If you do not wish to document the repro steps and save the screenshots, please consider recording a screen video instead and sending us a link to it.

    Please note that many VisualGDB issues are caused by selecting an incompatible combination of settings at some point. We are generally not able to review specific projects and find the specific settings that were set incorrectly. We recommend checking the projects into source control and keeping a track of all changed settings to avoid breaking the projects.

    You can also try checking various diagnostic output from various parts of VisualGDB as described on this page. Although we won’t be able to review it for a specific project unless the we can reproduce the problem from scratch, checking it might provide some clues on what is causing the unexpected behavior.

    #32782

    michael127001
    Participant

    I assume you are editing a cpp file in a VisualGDB project. I see what you mean that the next newline after typing template {{ is indented to the same length as the end of the word template. I thought you were typing ENTER literally at first 😅

    You can edit the clang-formatting settings at the document icon in the upper-right corner of the open source file:

    Clang-formatting in upper-right of source file

    I couldn’t find the exact setting to fix your issue, but you might find it in there. You can also try different formatting styles based on chromium, mozilla, google, etc. or disable the formatting entirely. I usually prefer to format on save or manually anyway.

    • This reply was modified 14 hours, 49 minutes ago by  michael127001.
    • This reply was modified 14 hours, 48 minutes ago by  michael127001.
    • This reply was modified 14 hours, 47 minutes ago by  michael127001.
    • This reply was modified 14 hours, 42 minutes ago by  michael127001.
Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.