System.TypeInitializationException on Windows Server 2016

Sysprogs forums Forums VisualGDB System.TypeInitializationException on Windows Server 2016

This topic contains 2 replies, has 2 voices, and was last updated by  support 1 week, 3 days ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #22989

    curtis.hendrix
    Participant

    I’m setting up a build agent on a Windows Server 2016 box.  Visual Studio 2017 Professional and VisualGDB 5.4.10.2582 are installed.

    Whenever I start Visual Studio, the following exception happens and VisualGDB does not get loaded into Visual Studio:

    #22990

    curtis.hendrix
    Participant

    Figured out the issue.  Using FIPS compliant algroithms needs to be disabled:

    Report Manager: “System.InvalidOperationException: This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.”

     

    “Or else, go to Local Security Policy (Start -> Run -> secpol.msc) and then go to “Security Settings -> Local Policies -> Security Options” and on the right-side windows you should see the policies in that please look for the Policy “System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing” and checked the security thing and it should be Enabled.”

     

    #22992

    support
    Keymaster

    Hi,

    Good to know it works. Just in case anyone else runs into the same problem, here’s another workaround to this: https://blogs.msdn.microsoft.com/shawnfa/2008/03/14/disabling-the-fips-algorithm-check/

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.