Stop gdb signals within VisualGDB

Sysprogs forums Forums VisualGDB Stop gdb signals within VisualGDB

This topic contains 1 reply, has 2 voices, and was last updated by  support 6 days, 1 hour ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #13158

    scottg183
    Participant

    I recently installed openssl package on the armv7 target I’m working on. After the install I now get a window within VS2010 indicating a SIGILL signal was received. From my research this is a known issue with openssl  and ARM 7 platforms. The suggested workaround is to use the “handle SIGILL nopass noprint nostop” command within gdb to remove that signal. Even though the command was successful VisualGDB continues to present the dialog box indicating the signal has occurred. Is there any way to stop this behavior?

    #13162

    support
    Keymaster

    Hi,

    Normally the command should work (unless you enter it in the “additional gdb commands” and your debug preferences override it). Either way, the recommended way of handling this is using the “Interrupts” window of VisualGDB (click the lightning icon in the GDB Session window). VisualGDB will let you modify signal handling from there and will also remember the settings for the next debug session.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.