Split: Failure with C++ tutorials

Sysprogs forums Forums VisualGDB Split: Failure with C++ tutorials

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #33989

    I have the same issue.   This is first use of VisualGDB.  Just following the tutorial as shown.  NOT A LINUX expert.  Tool chain was downloaded by VisualGDB.  Using build on Windows and deploy to RaspberryPi 4.  Everything works until VisualGDB tries a test.  Then get:

    Expected return code: 108. Actual return code: 127.
    Run “/home/charlie/projects/visualgdb/VisualGDB_ToolchainTestProgram_Deployed T” in directory “” on local computer
    bash: line 1: /home/charlie/projects/visualgdb/VisualGDB_ToolchainTestProgram_Deployed: No such file or directory
    Command exited with code 127

    please help



    It seems to get worse for me. I tried a new project with compile on remote. Looking at the project, it appears from the dependancies that VisualGDB is trying to compile a 32 bit app. My Raspberry Pi is running 64 bit.



    It looks like your toolchain is not compatible with your target. Please make sure you use a compatible toolchain.

    If you are not sure which toolchain you are using anymore, please follow the instructions on this page to reset everything. If it still doesn’t work, please share the repro steps including the screenshots (also showing how you write the SD card image) and we will point out the cause of the issue.

    If you are completely unfamiliar with the Linux toolchains and cross-compilation, and do not want to research it on your side, we can gladly walk you through everything at our consulting rate. Please contact our sales if you would like to get a quote.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.