Real-Time Watch timing not correct

Sysprogs forums Forums VisualGDB Real-Time Watch timing not correct

This topic contains 1 reply, has 2 voices, and was last updated by  support 1 month ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #29701

    bjornharink
    Participant

    L.S.

    I have an issue with the timing in Real-time watch. The timing is of. It assumes a clock of 16MHz, while it is 168MHz. When I do recalibrate in the “Time unit:” window at set it to 168MHz the timing makes sense. An osDelay(100) will last 100ms. In the original position it says 1053ms which comes down to 100*(168/16) = 1050. Unfortunately, after doing “Recalibrate” and restarting the debugging it resets itself. Is there something I am missing that needs to be set in the VisualGDB settings? I have tried to set the “Chronometer” to 168MHz, but that does not help.

    Thank you for your time.

    Kind regards Björn

    VisualGDB version: 5.5R4 (build 3920).

    #29702

    support
    Keymaster

    Hi,

    No worries. Please try calling ReportTicksPerSecond() from your code (it is defined in SysprogsProfiler.h) each time after the system clock frequency is changed. This will have the same effect as setting it manually.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.