Raspberry Pico profiling

Sysprogs forums Forums VisualGDB Raspberry Pico profiling

This topic contains 4 replies, has 2 voices, and was last updated by  Kanifol 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #31657

    Kanifol
    Participant

    Hi! I want to improve debugging of rpi pico and try to enable Profiling. Something going wrong and build failed. VGDB tell me that some files is missing, but they don’t.

    ../../../pico-sdk/src/rp2_common/hardware_timer/timer.c:8:10: fatal error: hardware/irq.h: No such file or directory
    8 | #include “hardware/irq.h”
    | ^~~~~~~~~~~~~~~~

    C:/Users/kochnevsv/AppData/Local/VisualGDB/EmbeddedEFPs/Profiler/ProfilerDriver_RP2040.cpp:3:10: fatal error: pico/stdio/driver.h: No such file or directory
    3 | #include “pico/stdio/driver.h”
    | ^~~~~~~~~~~~~~~~~~~~~

    Then i turn on Chronometer, but it always show me 0sec.

    Any recomendations?

    #31673

    support
    Keymaster

    Thanks for confirming your license key. We have linked it to your forum profile.

    Profiling the PicoSDK-based projects indeed requires a bit of additional setup. We have just published a tutorial explaining everything step-by-step. Feel free to follow it and use it as a working reference. Please make sure you are using the latest VisualGDB 5.6 release (not the Beta).

    The Chronometer relies on the DWT cycle counter in order to determine how much time has passed between events. It will indeed not work if any part of your code (e.g. the instrumenting profiler) also uses it. You can find out the exact GDB commands used by VisualGDB to read and reset the cycle counter by checking the C:\Program Files (x86)\Sysprogs\VisualGDB\TimestampProviders\DWT.xml file.

    • This reply was modified 1 month, 1 week ago by  support.
    #31680

    Kanifol
    Participant

    Hi!

    I’m having trouble installing version 1.3.0 of SDK. There is no choise in drop down menu on tab “Pre-package Release” and “Git Tag”. I downloaded it manualy and tried to add from “Existing Checkout”. The next tab “Project Sample” does not contain any examples and i can’t continue…

     

    VisualGDB updated to 5.6 release.

    #31682

    support
    Keymaster

    Hi,

    No problem. Please try opening Tools->VisualGDB->Manage VisualGDB Packages -> Updates. This will refresh the VisualGDB package cache, and the 1.3.0 SDK will appear in the SDK list.

    Please also make sure you remove any incomplete SDK downloads to reduce the chances of confusion.

    #31731

    Kanifol
    Participant

    Thanks!

    It worked for me!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.