Problem with Custom Shortcuts

Sysprogs forums Forums VisualGDB Problem with Custom Shortcuts

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by  support 3 weeks, 1 day ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #31254

    jcardenas
    Participant

    Hi, i have loaded an exisiting makefile managed project for cross-compiling and works fine.

    I did this proccess by New Project -> Linux Project Wizard -> Import a Project -> Import a project build with other tools

    And finally i configured the build and target machines.

    The problem is that this project has some custom targets like “make check” and “make valgrind” for running unittests and  valgrind analysis. I have added both targets to custom shortcuts in

    visualGDB project properties but i have some problems.

    • The first one is that i get a “command not found.” error and i don’t know how to fix it. I attach custom shortcuts configuration and error log.
    • The second one is that if i first run “Run tests” shortcut (the first one) and the i run “Run Valgrind” (the second one), then if i run “Run tests” again “Run valgrind” is run and i can’t run run tests until i restart visual studio.

     

    Attachments:
    You must be logged in to view attached files.
    #31257

    support
    Keymaster

    Hi,

    It looks like you have specified the commands incorrectly. Please try updating them as shown below:

    Command: make
    Arguments: check

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.