"Object reference not set to an instance of an object."

Sysprogs forums Forums VisualGDB "Object reference not set to an instance of an object."

This topic contains 8 replies, has 3 voices, and was last updated by  support 10 years, 1 month ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #556

    Anonymous
    Participant

    Hi all,

    as another step for integrating VisualGDB in my company I am having problems with the VisualGDB project properties.

    The point is that I started working with a Visual Studio 2008 project (not generated with the VisualGDB wizard project creation tool), and then I started to add all the necessary stuff in the solution and project files for using VGDB on it.

    The point is that this message “Object reference not set to an instance of an object.” is being shown every time I want to open the VisualGDB project properties. I do not know if I am doing something wrong or I need to do or add something else to have this working properly. Maybe it is a problem with some file name or the properties file name but I can not solve it.

    By the moment these are the file names:
    – Elite_WIN32.sln for the solution
    – Elite_WIN32.vcproj the project file
    – “Debug GDB” the name of the configuration (maybe there could be a problem with the space in the name of the configuration?)
    – Elite_WIN32-Debug GDB.vgdbsettings the VisualGDB settings file

    Greetings,
    Javier

    #2363

    Anonymous
    Participant

    Hi,

    in fact I have just converted the project to VS2010 and the VisualGDB properties UI works well. So it seems a problem with the current implementation using VS2008.

    Could it be possible to have this working in a future version of VisualGDB? Because it would not be possible in some cases to convert all our projects to VS2010.

    Thanks,
    Javier

    #2364

    support
    Keymaster

    Hi,

    Please change the configuration type to “Makefile project” in Visual Studio project properties (not VisualGDB project properties).

    #2357

    Anonymous
    Participant

    Sure,

    the project properties were always set to Makefile project and it does not work in VS2008.

    This is the data of the configuration inside the project file:


    Name=”DebugGDB|Win32″
    OutputDirectory=”$(SolutionDir)$(ConfigurationName)”
    IntermediateDirectory=”$(ConfigurationName)”
    ConfigurationType=”0″
    >

    Name=”VCNMakeTool”
    BuildCommandLine=”VisualGDB “$(VISUALGDB_DIR)VisualGDB.exe” /build “Elite_WIN32-DebugGDB.vgdbsettings”
    ReBuildCommandLine=”VisualGDB “$(VISUALGDB_DIR)VisualGDB.exe” /rebuild “Elite_WIN32-DebugGDB.vgdbsettings”
    CleanCommandLine=”VisualGDB “$(VISUALGDB_DIR)VisualGDB.exe” /clean “Elite_WIN32-DebugGDB.vgdbsettings”
    Output=”C:Program Files (x86)SysprogsVisualGDBUseStartDebugWithGDBCommand.exe”
    PreprocessorDefinitions=””
    IncludeSearchPath=””
    ForcedIncludes=””
    AssemblySearchPath=””
    ForcedUsingAssemblies=””
    CompileAsManaged=””
    />

    Where VisualGDB in the command lines is a batch file receiving 3 parameters.

    And this is properly set in the project properties window in VS2008.

    #2362

    support
    Keymaster

    That is strange. Please send us an archive containing the following files from your project/solution:

    1. *.sln
    2. *.vcproj
    3. *.vgdbsettings

    This will help us reproduce the problem on our side and provide you with a solution.

    #2361

    cdoty
    Participant

    I had this happen when I had A group outside of the Source files group, in the project.

    My project was set up like this:

    Header files
    Java Source Files
    Libraries
    Resource files
    Source files

    Once I removed the Libraries group, the VisualGDB projects settings started working.

    #2360

    support
    Keymaster

    Hi,

    Could you please send us your .vcprojx file and the .filters files so that we could reproduce and fix your problem?
    There was a bug in v2.7 that could cause this, however it was fixed in v3.0.

    #2358

    cdoty
    Participant

    @bazis wrote:

    Hi,

    Could you please send us your .vcprojx file and the .filters files so that we could reproduce and fix your problem?
    There was a bug in v2.7 that could cause this, however it was fixed in v3.0.

    I have 2.8 installed and it’s a Visual Studio 2008 project. Here’s a link to the project and solution files:

    http://www.rastersoft.net/files/BadProject.rar

    #2359

    cdoty
    Participant

    This does work correctly in 3.0 beta 3.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.