New tutorial for adf project

Sysprogs forums Forums VisualGDB New tutorial for adf project

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #35228


    Is there a newer version for creating an adf project than the 2019 posted tutorial?

    I am now using the ESP32-S3 and esp-idf 5.1 for all my projects and wanting to use ESP-ADF version 2.6 with it.

    If this is not supported or not tested. What is the latest version adf framework that has been tested and which version of idf required?



    Further to my post. I have created an adf 4.6 project and it appears the issue is the python dependencies. When I look at visualgdb package manager I see it is using Python 3.8.

    I delete the python directory path in tools ->options ->visualgdb

    When I restart the project it prompts python is missing and get option to select version 2.7 or 3. I select 3 but still get same depedency eerors.

    My machine also has python 3.11 installed and wonder if it is trying to use parts of this instead? I also see the environment path for python is not set.

    I am not sure what I need to do, do I have to just change the path to python to add the one in sysgcc, or do I need to change something in Visual Studio (2022)?

    Double clicking error takes me to this code:

    idf_build_get_property(python PYTHON)
    idf_build_get_property(idf_path IDF_PATH)
    message(STATUS “Checking Python dependencies…”)
    execute_process(COMMAND “${python}” “${idf_path}/tools/”
    if(result EQUAL 1)
    # check_python_dependencies returns error code 1 on failure
    message(FATAL_ERROR “Some Python dependencies must be installed. Check above message for details.”)
    elseif(NOT result EQUAL 0)
    # means failed to run at all, result should be an error message
    message(FATAL_ERROR “Failed to run Python dependency check. Python: ${python}, Error: ${result}”)

    This is the output of the build relating to the python dependencies.

    The following Python requirements are not satisfied:
    gdbgui==; python_version < “3.11”
    pygdbmi<=; python_version < “3.11”
    python-socketio<5; python_version < “3.11”
    itsdangerous<2.1; python_version < “3.11”
    esp-windows-curses; sys_platform == ‘win32’
    Please follow the instructions found in the “Set up the tools” section of ESP-IDF Getting Started Guide
    Diagnostic information:
    IDF_PYTHON_ENV_PATH: (not set)
    Python interpreter used: C:\Users\david\AppData\Local\VisualGDB\Python3\python.exe
    Warning: python interpreter not running from IDF_PYTHON_ENV_PATH
    PATH: C:\Program Files\Git\bin;C:\Users\david\AppData\Local\VisualGDB\Python3;c:\SysGCC\esp32\tools\xtensa-esp32-elf\esp-12.2.0_20230208\xtensa-esp32-elf\bin;c:\SysGCC\esp32\tools\xtensa-esp32-elf\esp-12.2.0_20230208\xtensa-esp32-elf\bin;c:\SysGCC\esp32\tools\xtensa-esp32s2-elf\esp-12.2.0_20230208\xtensa-esp32s2-elf\bin;c:\SysGCC\esp32\tools\xtensa-esp32s3-elf\esp-12.2.0_20230208\xtensa-esp32s3-elf\bin;c:\SysGCC\esp32\tools\esp32ulp-elf\2.35_20220830\esp32ulp-elf\bin;c:\SysGCC\esp32\tools\riscv32-esp-elf\esp-12.2.0_20230208\riscv32-esp-elf\bin;c:\SysGCC\esp32\tools\idf-exe\1.0.3;c:\SysGCC\esp32\tools\ccache\4.8\ccache-4.8-windows-x86_64;c:\SysGCC\esp32\tools\ninja\1.10.2;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\WINDOWS\System32\OpenSSH\;C:\Program Files\dotnet\;C:\Program Files\Microchip\xc32\v4.30\bin;C:\Program Files\Git\cmd;C:\Program Files\PuTTY\;C:\Program Files\nodejs\;C:\Users\david\AppData\Local\Programs\Python\Python311\Scripts\;C:\Users\david\AppData\Local\Programs\Python\Python311\;C:\Users\david\AppData\Local\Microsoft\WindowsApps;C:\Users\david\AppData\Local\GitHubDesktop\bin;C:\Users\david\AppData\Local\Programs\Microsoft VS Code\bin;C:\Users\david\.espressif\tools\openocd-esp32\v0.12.0-esp32-20230419\openocd-esp32\bin;C:\Users\david\AppData\Roaming\npm;C:\Users\david\AppData\Roaming\Python\Python311\Scripts;C:\Users\david\.dotnet\tools;C:\Users\david\esp\esp-adf;
    CMake Error at C:/SysGCC/esp32/esp-adf/v2.6/esp-idf/tools/cmake/build.cmake:296 (message):
    Some Python dependencies must be installed. Check above message for



    We have not recreated the tutorial because there have not been any major changes to the ESP-ADF workflow. We had added a note in step 4 here explaining how to find out the toolchain version compatible with ESP-ADF and a separate section here, explaining how ESP-ADF and ESP-IDF work together.

    The compatibility between specific versions of ESP-ADF, ESP-IDF, the toolchains and Python is up to Espressif. All we do is briefly retest the stable ESP-IDF releases with the corresponding toolchains, and release them as ready-to-install packages. ESP-ADF has considerably fewer users than ESP-IDF, so we do not retest it that often, sorry.

    If you are running into strange problems with ESP-ADF and Python, we would suggest troubleshooting it as follows:

    1. Reset your Python environment as described here.
    2. Find out the exact versions of ESP-IDF, ESP-ADF and the toolchain you want to use (per Espressif documentation).
    3. Install the corresponding toolchain via VisualGDB Package Manager.
    4. Install ESP-ADF into that toolchain as shown here.

    If it still doesn’t work, you could be still using incompatible versions of Espressif packages. We would advise first getting it to work outside VisualGDB, then taking note of the exact versions that actually work, and double-checking that VisualGDB is using the same versions. You can always export the build command used by VisualGDB to a batch file as shown here, and experiment with it (e.g. patch it to use a different Python environment, or a different ESP-IDF version).

    As far as our support goes, we can help you find VisualGDB settings that control specific parts of the build (e.g. which ESP-ADF version is used by a specific project), but it’s up to you to find a working combination of parts provided by Espressif.


    I am having difficulty doing the build of a project/example of the esp-ADF sdk

    error report

    — Configuring incomplete, errors occurred!
    CMake Error at C:/SysGCC/esp32/esp-adf/master/esp-idf/tools/cmake/targets.cmake:81 (message):
    Toolchain file
    not found
    Call Stack (most recent call first):
    C:/SysGCC/esp32/esp-adf/master/esp-idf/tools/cmake/project.cmake:285 (__target_set_toolchain)
    CMakeLists.txt:8 (project)

    System.Exception: CMake exited with code 1in ey.a1(q b, Object a)

    this by selecting as SDK Checkout Master in esp-adf/master and esp32c6 as device

    I have tried following the procedure several times but always run into this error.

    This is my configuration

    esp-idf 5.2
    esp-adf master





    Can you help me? I still have the usual error and can’t move forward.

    Kind Regards



    Most likely, you are using incompatible versions of ESP-IDF, ADF and the toolchain. Please refer to this page for more information:

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.