Multiple platform project settings separation

Sysprogs forums Forums VisualGDB Multiple platform project settings separation

This topic contains 1 reply, has 2 voices, and was last updated by  support 1 month ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #32663

    cesaretiveron
    Participant

    Hi,

    I’m currently working on a project that can target two different Linux platforms. In this situation I managed to keep different project settings for each platform by enabling all the checkboxes under “Separate settings for:” in the “Manage Platform and Configurations” window (see attached screenshot).
    However this option doesn’t seem to work with the following sections of the Project Properties window:

    • Custom build steps
    • Custom debug steps
    • User variables

     

    This is an issue with my project because different settings needs to be applied for each platform under those sections. Is there a way to fix this behaviour?

    Thank you

    Attachments:
    You must be logged in to view attached files.
    #32669

    support
    Keymaster

    Hi,

    Indeed, the custom build/debug steps, are shared between multiple project configurations. The easiest way to have run different actions depending on the configuration platforms is to use the “Reference a reusable action list” action with a variable-based path (e.g. $(PlatformName).vgdbxactions).

    The user variable values are stored in per-user files (e.g. <Project>.<UserName>.user), so having them differ between platforms would cause conflicts. Instead, we would advise having the variables for all platforms defined together, and then using them depending on the platform, e.g.:

    • The variable list defines DeployHostARM and DeployHostX86
    • The ARM platform references $(DeployHostARM)
    • The X86 platform references $(DeployHostX86)

    If this doesn’t work, feel free to let us know more about your setup, and we will try to suggest a better layout.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.