msp430 gcc large mode placement

Sysprogs forums Forums VisualGDB msp430 gcc large mode placement

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by  support 1 week, 3 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #31319

    chrisalfred
    Participant

    I am using an MSP430FR2476 which has 64k. My project is larger than the lower 32k and gcc is not placing the extra code in the high memory even with -mlarge mode.

    What do I have to do to get the compiler to place code in the high memory?

    #31320

    support
    Keymaster

    Hi,

    This is something to check in the MSP430 GCC documentation. E.g. you may need to specify it to both compiler and linker, or to specify some additional settings.

    You can also verify the exact flags passed by VisualGDB to GCC by reviewing the RSP files (MSBuild) or adding “-v” to Ninja¬† command line (CMake).

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.