mbed failed to symlink arm-none-eabi-addr2line.exe

Sysprogs forums Forums VisualGDB mbed failed to symlink arm-none-eabi-addr2line.exe

Tagged: 

This topic contains 9 replies, has 2 voices, and was last updated by  dave93cab 1 month, 3 weeks ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #29985

    dave93cab
    Participant

    I have a fresh install of visualgdb, created an mbed project, followed the patching of gcc.py instuctions but cannot build my project (which is just blinky). I get the following build error:

     

    Failed to symlink C:\<project dir>\Build\NUCLEO_F411RE\Debug\.ccachedir\arm-none-eabi-addr2line.exe to C:\<homedir>\AppData\Local\VisualGDB\CCache\ccache.exe

     

    Any ideas? Thanks

    #29986

    support
    Keymaster

    Hi,

    This looks like an issue with mbed itself rather than VisualGDB. It could be caused by a buggy platform definition, incompatible settings, or unsupported combination of tools. Please try building the project manually using mbed-cli and check if the problem persists.

    You can extract the command line used by VisualGDB by locating the build command line in the VisualGDB Build window (shown in cyan), right-clicking on it and selecting “Dump to a batch file”.

    If the project builds manually, but doesn’t build under VisualGDB, please let us know and we will help you configure VisualGDB to match the results of the manual build.

    #29987

    dave93cab
    Participant

    Wasn’t using the ARM toolchain, manually selecting that fixed it.

     

    EDIT: no it didn’t, sorry. will follow your advice above

    • This reply was modified 1 month, 3 weeks ago by  dave93cab.
    #29989

    dave93cab
    Participant

    Where does the dump to batch file save the file? Doesn’t appear to do anything and I checked in the project folder. Thanks

    #29990

    dave93cab
    Participant

    Ah ok so when I created a new project without ccache enabled I see the cyan, and that does export the command to batch file. I was clicking on the red error line, there is no cyan when ccache is enabled

    #29993

    support
    Keymaster

    Hi,

    We have rechecked the command dumping with ccache enabled and it did work as expected. If it doesn’t work on your side, please share a screenshot of the entire Visual Studio window showing the VisualGDB Build log from the very beginning, and we will investigate this further.

    #29999

    dave93cab
    Participant

    There’s not much in the log when I try to build it

    Attachments:
    You must be logged in to view attached files.
    #30010

    support
    Keymaster

    This happens because the build fails due to an error shown on the screenshot. Most likely, your Visual Studio process does not have permissions to create symbolic links. Please try running Visual Studio as administrator.

    #30018

    dave93cab
    Participant

    That worked but I am assuming that running VS as Administrator is not usually required? I will look into it further, thanks for the help

    #30019

    dave93cab
    Participant

    Found a GPO to allow creation of symlinks, and it’s working. Thanks again

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.