Linking-Error: arm-eabi/bin/ld.exe: cannot find -lBIQ_CM4_GCC

Sysprogs forums Forums VisualGDB Linking-Error: arm-eabi/bin/ld.exe: cannot find -lBIQ_CM4_GCC

This topic contains 4 replies, has 2 voices, and was last updated by  support 2 months, 4 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #25371

    runout
    Participant

    Hi,

    there is a software package from ST-Micro “STM32CubeExpansion_Audio_V1.1.1”
    with support for Audio-Processing. (Mute/Filter etc.)

    It compiles completely.
    Linking failed!

    The Lib-Properties seems correct.

    1>Linking ../VisualGDB/Debug/Project…
    1>c:/sysgcc/arm-eabi/bin/../lib/gcc/arm-eabi/7.2.0/../../../../arm-eabi/bin/ld.exe: cannot find -lBIQ_CM4_GCC
    1>collect2.exe : error : ld returned 1 exit status

    What is the Reason for this Link-Error?
    Wrong Version, wrong Lib.

    Compiling/Linking with Keil 5 works.

    Kind Regards
    Thomas

    Attachments:
    You must be logged in to view attached files.
    #25374

    support
    Keymaster

    It looks like the project requires the BIQ_CM4_GCC library that could not be located in the standard library search paths.

    Please try locating the library manually (it should normally be shipped together with the project) and add its directory to the Library Directories field in VisualGDB Project Properties.

    You can find out more about library-related settings here: https://visualgdb.com/support/linkerinputs/

    #25380

    runout
    Participant

    Hi,

    you’ve seen my attachment?

    An Entry in “Additional Linker Inputs” also not works.

    The Raw-Name of the Lib is “BIQ_CM4_GCC.a” (not libBIQ_CM4_GCC.a)
    Maybe a Issue with the name conventions?

    Is there a Visual-GDB-Menu for setup the Linker Options?
    (verbose e.g.)

    Kind regards
    Thomas

     

    #25381

    runout
    Participant

    Edit: Problem solved (Name-Convention)
    <lib>LibName<.a> is the required format (at least at Arm-GCC)

     

    #25383

    support
    Keymaster

    Sorry for the confusion. If the physical library name doesn’t include the “lib” prefix, the easiest way to add it to the project would be to simply add it to the Solution Explorer as if it was a source file (Add->Existing Item). This will have the same effect as using the “Additional linker inputs” field, but will make it slightly easier to manage.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.