Linker cannot find path

Sysprogs forums Forums VisualGDB Linker cannot find path

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #35463


    I have a strange problem. I am building a unit test project and I am attempting to include some additional source files. When I attempt to build, I get a linker error:

    Linking ../VisualGDB/Debug/Cerus32.UnitTests...
    c:/sysgcc/arm-eabi/bin/../lib/gcc/arm-none-eabi/12.3.1/../../../../arm-none-eabi/bin/ld.exe: cannot find C:/Development/Cerus32/Cerus32/Inc: Permission denied
    Build failed: arm-none-eabi-g++.exe exited with code 1
    collect2.exe: error: ld returned 1 exit status

    I know that this path exists.  But when I click on the linked path in the ‘VisualGDB Build’ output, I get the attached error showing a different path which does not exist.  It seems that for some reason VisualGDB is converting the correct path:


    into the incorrect path:


    There is nothing in the Path Mapping section of the project properties.

    Could anyone please advise why this is happening and how I can stop it?



    You must be logged in to view attached files.


    It looks like you have specified invalid settings at some point. Unfortunately, it’s impossible to suggest anything meaningful without knowing what exact settings you have used.

    Please try creating a new project from scratch, ensure that it builds, and then try changing one setting at a time until the problem triggers. Once you can reproduce it, please share a screenshot of the exact setting you changed and we will try to suggest a workaround.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.