"Invisible" project properties

Sysprogs forums Forums VisualGDB "Invisible" project properties

This topic contains 8 replies, has 2 voices, and was last updated by  jmkresse 2 months, 2 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #11033

    jmkresse
    Participant

    Why, when I click on “VisualGDB Project Properties” under “Project”, does it not display the VisualGDB Project Properties?

    #11034

    jmkresse
    Participant

    To clarify, that usually works; but then it appears to stop working for a project, and will not work again. (When I click on “VisualGDB Project Properties”, nothing appears to happen.)

    I do have the workaround of bringing up the appropriate .vdgbsettings file, but it’s far easier to explain to my other users how to do things the other way.

    #11042

    support
    Keymaster

    Hi,

    This could happen if the property used to store the location of the .vgdbsettings file was set incorrectly. Please try holding Shift while right-clicking on the project and VisualGDB will display the corresponding menu item even if it cannot confirm that it’s a valid VisualGDB Project. It may then display an error that will help locate the root cause for this.

    If it does not help, please let us know if it’s an MSBuild-based project or not and we will suggest further diagnostic steps.

    #11357

    jmkresse
    Participant

    This issue just appeared in a new project. It it GNU make-based. When I did a Shift-right click on the Project tab, it did not display an error.

    #11358

    jmkresse
    Participant

    Now it doesn’t even show the VisualGDB settings in the Solution Explorer, or show “VisualGDB properties” under Project.

    Do I need to redo the entire project?

    #11359

    support
    Keymaster

    Hi,

    This could happen if the .vgdbsettings file got corrupt or the NMake project settings were modified so that the .vgdbsettings file is no longer specified as the project output.

    When you hold Shift, does the VisualGDB Project Properties window show the correct settings? Does opening View->Other Windows->VisualGDB Diagnostics Console and right-clicking on the project again show any error messages?

    #11372

    jmkresse
    Participant

    I reverted the directory to an earlier, known good, version, and the issue has gone away. If it reappears, I will try these steps.

    Again, I’m using GNU make, not NMake.

    Also, can you explain what you mean when you say:

    When you hold Shift, does the VisualGDB Project Properties window show the correct settings?

    Thanks!

    #11375

    support
    Keymaster

    Hi,

    Sorry for the confusion, we will try to clarify.

    Visual Studio views the non-MSBuild VisualGDB projects as NMake projects (Visual Studio itself does not know the details about GNU Make vs CMake vs QMake and simply invokes VisualGDB to do the build). In order for those projects to work correctly, their VS-level settings should be configured as shown below:

    If the ‘output’ is not set to a .vgdbsettings file, VisualGDB won’t treat this project as its own project and won’t show the settings command. If you manually manipulate the VS project configurations via the VS GUI, you could accidentally break those settings, causing VisualGDB to stop treating the project as a VisualGDB-based project.

    Normally if you hold ‘Shift’ while right-clicking on the project, VisualGDB will show its context menu command and try to load the settings from the default file path (<project>-<configuration>.vgdbsettings). If the corresponding .vgdbsettings file is missing, VisualGDB will show default project settings that won’t reflect any of your project’s customizations. Hence the easiest way to check if the .vgdbsettings file is still valid and readable is to open the VisualGDB Project Properties while holding ‘shift’ and check that the settings look correct (e.g. the project type is set to the type you are using and not the default “Windows project”).

    #11381

    jmkresse
    Participant

    Thanks for this information!

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.